My workspace extends, and is not a mirror or copy of original display, but I still get the vertical purple Icon launcher bar on both screens and see no way to remove it. Please advise!

  • is it also possible to remove toolbar with clock on top of the screen? – user339907 Oct 18 '14 at 12:17

You can configure whether the launcher will show on all monitors or in a single one:

Open the dash and type display

Now configure where you want the launcher to appear:

enter image description here

  • Thanks, this did it. Even though 12.04 thinks my dual-monitor desktop pc setup is in fact a massive (3200 x 1080) laptop screen. – jdv May 5 '12 at 5:45
  • That's because, for any practical purpose, it is. As you said yourself, your workspace extends (as opposed to clone/mirror or dual-screen), so for any application you do have a massive 3200x1800 screen. That's the size of your single workspace. – MestreLion May 5 '12 at 6:32
  • 1
    Sadly this doesn't work with nVidia's TwinView. There is only one screen there ("Laptop") and while selecting it does remove the launcher from one of my displays, it is not the one I want. – Timmmm Jul 14 '12 at 15:51
  • @Timmmm: I am not sure how Nvidia's TwinView works. Is that some sort of "clone" displays, where both show the same content? Anyway, it is a pity Nvidia's software does not play nice with Ubuntu and Linux in general. I use ATI/AMD, and their proprietary control panel (Catalyst) and it shows the same displays and configuration as in Ubuntu's built in tool. Well, NVidia is widely known for being extremely uncooperative with the open software world. – MestreLion Aug 14 '12 at 12:40
  • 1
    nVidia users cheer up and have a look at the accepted answer to this question: askubuntu.com/q/107583/64513 Also it seems starting from driver version 3xx nvidia integrates better in the system but I can't verify this at the moment. – nuala Nov 4 '12 at 14:03

If you have an Nvidia video card you need to run the Nvidia software and change the primary display. Don't know about other chipsets

  • But the sticky edges stays on even if you turn them off, which is a bit of a pain! – SimplySimon Jun 6 '13 at 13:49

Do you mean the 'Launcher' (which contains the Ubuntu symbol, Home folder, Ubuntu Software Manager, Ubuntu One, etc etc) on the left of the screen? If yes, then follow these instructions:

  1. On the desktop, right-click and select Change Desktop Background.
  2. Switch to Behavior tab.
  3. Change Auto-hide the Launcher from OFF to ON.
  • I appreciate your reply. This enables autohide of the HUD on both monitors, but I wish to remove the launcher from only my second monitor (and not to hide it, which still interferes with the mouse movement across screens). – jdv May 5 '12 at 5:42
  • Totally forgot that when we Auto-hide, it hides on both monitors sigh* sorry :) – Mohd Arafat Hossain May 5 '12 at 6:15

Nvidia users, just disable "Xinerama", restart lightdm and then make changes to Display and Enable Xinerama.


  1. edit /etc/X11/xorg.conf
  2. change Xinerama value from 1 to 0
  3. service lightdm restart
  4. System Settings -> Display -> Launcher placement -> select monitor
  5. edit /etc/X11/xorg.conf
  6. change Xinerama value from 0 to 1
  7. service lightdm restart

You can disable sticky edge this way too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.