2

I wanted to install sass version 3.2.0 alpha.

I first ran sudo apt-get install libhaml-ruby1.8, which is what the console recommended It successfully installed, but it installed an older version of sass.

Just in case, I tried installing it via rubygems:

sudo apt-get install rubygems1.8
sudo gem install sass

This just reinstalled sass 3.1.17. As per the recommendation here, I tried running the following:

sudo gem uninstall -Iax sass
sudo gem install sass --pre

This stated that sass 3.2.0 alpha was successfully installed. However, sass no longer seems to work at all. Typing

sass --watch styles.scss

...returns...

The program 'sass' is currently not installed.  You can install it by typing:
suto apt-get install libhaml-ruby1.8

So now I've gone full circle. What can I do to get sass working from the console?

  • gem and distribution package management are not the same thing. i already did by civic duty on PPAs today – RobotHumans May 5 '12 at 4:38
  • @aking1012: Ok, thanks for the hint -- I'll do some more googling. Could you perhaps link to where you already talked about PPAs? – Michael0x2a May 5 '12 at 5:55
0

You need to add /var/lib/gems/1.8/bin/ to your path

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.