1

I am Ubuntu 18. I am using terminator as my terminal client. Terminator runs using python 2. I am using Python 3.9 as default since several application in my machine require that version. But when python 3.9 is set as default, I am unable to launch terminator. The error thrown is as follows:

File "/usr/bin/terminator", line 123 except (KeyError,ValueError), ex: ^ SyntaxError: invalid syntax

Is there a way to configure terminator to use python 2 while keeping python 3.9 as the default version. The option I could think of was by editing the terminator.desktop file and changing the launch command to use python 2. Is there any other way to achieve this?

2
  • Why are you using an old version of terminator, when terminator 2 is using python 3? Feb 22 at 9:44
  • Ubuntu 18? Ubuntu desktop and server releases have a yy.mm format, and whilst specialist snap based releases like Ubuntu Core 18 for IoT appliances do use a yy format there are none titled just Ubuntu 18. Please clarify your release as there is no Ubuntu 18. Ubuntu has used year only releases since 2016 to specify snap only releases so are you talking about a Ubuntu Core or other like release?
    – guiverc
    Feb 22 at 10:06
2

As an alternative you can install newer version of Terminator from Ubuntu 20.04 LTS by:

cd ~/Downloads
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/t/terminator/terminator_1.91-4ubuntu1_all.deb
sudo apt-get install ./terminator_1.91-4ubuntu1_all.deb

or from upcoming 21.04:

cd ~/Downloads
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/t/terminator/terminator_2.1.0-1_all.deb
sudo apt-get install ./terminator_2.1.0-1_all.deb

It depends on Python 3, so should work with it.

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.