I am trying to set ZSH as my default shell, however it keeps reverting back to bash.

I have tried this code:

sudo chsh -s $(which zsh)

I've also tried:

sudo chsh -s /bin/zsh 

Also tried these commands without sudo. Any ideas on what else I need to do. When running ZSH from within bash it loads up and works fine but I'd like to set it as the default shell.


Just using chsh:

chsh -s $(which zsh)

without sudo should work. If you use sudo it will change the shell not for your working user but for root

Finally, log out of your computer and log back in.


  • 17
    I have the same problem and the answer doesn't solve it – Aswin Murugesh Jul 21 '13 at 16:11
  • @AswinMurugesh Check my answer – Shailesh Kalamkar Aug 11 '15 at 5:30
  • 9
    you can also run sudo chsh -s /bin/zsh userName – Micha Roon Sep 30 '15 at 10:49
  • 13
    Note: I had to restart my system before this would take effect. – KevinO Oct 12 '15 at 0:38
  • no, it did not work. – Haha TTpro Feb 25 '18 at 4:33

I found this on superuser forum

Open /etc/passwd:

sudo vi /etc/passwd

Find the line with your username:

username:x:1634231:100:Your Name:/home/username:/bin/bash

and replace bash with zsh:

username:x:1634231:100:Your Name:/home/username:/bin/zsh

Log out and log in back for the changes to take effect.

  • 11
    You should be very careful with this approach - it's not usually the best idea to go mucking around with /etc/passwd – Thomas Ward Jan 7 '16 at 13:13
  • Even though I didn't use this method, it helped me verify the effect of chsh -s `which zsh` – jchook Sep 30 '17 at 0:43
  • HA Yea this total fucked my user. Can't log back in. – Mark Carpenter Jr Jul 16 '18 at 0:23

You may also do this:

open your bashrc file in your favourite editor

sudo nano ~/.bashrc

then add the line below top of the file

exec zsh

It will execute the command every time you load the terminal and run your zsh shell.

  • 13
    and it will also break all your non-interactive jobs (scp for example). – Jakuje Mar 11 '16 at 16:45
  • Sorry for the downvote, but changing /etc/passwd or chsh are better solutions and more reliable. – Timo Dec 25 '18 at 11:57
  • Thanks that did it. @Timo I did the change on /etc/passwd and or chsh but my default kept going back to bash. I added exec zsh as per posted response and it worked. – Stryker Feb 11 at 21:42

If zsh is not /bin/zsh then chsh won't work. On Ubuntu it is /usr/bin/zsh. so doing chsh -s /usr/bin/zsh or chsh -s `which zsh` should work. Also need to re-login to desktop session.

  • On my Ubuntu VPS it's /bin/zsh – Wilhelm Erasmus Dec 9 '15 at 12:39
  • On my Ubuntu, I see it in both /bin/zsh and /usr/bin/zsh – blue_chip Apr 10 '17 at 14:34
  • 2
    On mine (14.04, with zsh from main repo), there are two zsh's, and they are both two-layer symlinks: /usr/bin/zsh -> /etc/alternatives/zsh-usrbin -> /bin/zsh5 and /bin/zsh -> /etc/alternatives/zsh -> /bin/zsh5 – wjandrea Oct 21 '17 at 0:36

I had an issue with permissions to change shell under the current user but next helps me (you should set correct 'zsh' folder for your computer):

sudo chsh -s /bin/zsh <myUserName>

Strange, the "accepted" answer didn't work for me as I got

chsh: PAM: Authentication failure

To solve this issue edit your /etc/passwd and make sure it points to the zsh location. (You can find this by running "which zsh") In my case my user called "webmaster" looked like this:

  • I believe it's supposed to ask for a password. I got the same error on my previous mint install. Current one worked fine though – Wilhelm Erasmus Dec 9 '15 at 12:40
  • Someone else had the same problem, and it turned out they had ran chsh -s zsh, which made their passwd entry incorrect. – wjandrea Oct 21 '17 at 0:46

Type in the terminal

sudo chsh -s $(which zsh) root

protected by Zanna Jan 2 '17 at 21:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.