292

I am trying to set ZSH as my default shell, however it keeps reverting back to bash.

I have tried this code:

sudo chsh -s $(which zsh)

I've also tried:

sudo chsh -s /bin/zsh 

Also tried these commands without sudo. Any ideas on what else I need to do. When running ZSH from within bash it loads up and works fine but I'd like to set it as the default shell.

1
  • 6
    quick answer that worked for me: logging out and then logging back in to the desktop session fixed it for me.
    – aderchox
    Jul 13, 2020 at 23:27

7 Answers 7

477

Just using chsh:

chsh -s $(which zsh)

without sudo should work. If you use sudo it will change the shell not for your working user but for root

Finally, log out of your computer and log back in.

Troubleshooting:

14
  • 37
    I have the same problem and the answer doesn't solve it Jul 21, 2013 at 16:11
  • @AswinMurugesh Check my answer Aug 11, 2015 at 5:30
  • 18
    you can also run sudo chsh -s /bin/zsh userName
    – Micha Roon
    Sep 30, 2015 at 10:49
  • 35
    Note: I had to restart my system before this would take effect.
    – KevinO
    Oct 12, 2015 at 0:38
  • 5
    Rebooting on Linut Mint 19.2 is needed to have zsh take over. sudo reboot gets the job done.
    – llinfeng
    Dec 7, 2019 at 0:55
69

I found this on superuser forum

Open /etc/passwd:

sudo vi /etc/passwd

Find the line with your username:

username:x:1634231:100:Your Name:/home/username:/bin/bash

and replace bash with zsh:

username:x:1634231:100:Your Name:/home/username:/bin/zsh

Log out and log in back for the changes to take effect.

2
  • 26
    You should be very careful with this approach - it's not usually the best idea to go mucking around with /etc/passwd
    – Thomas Ward
    Jan 7, 2016 at 13:13
  • 5
    Even though I didn't use this method, it helped me verify the effect of chsh -s `which zsh`
    – jchook
    Sep 30, 2017 at 0:43
39

You may also do this:

open your bashrc file in your favourite editor

sudo nano ~/.bashrc

then add the line below top of the file

exec zsh

It will execute the command every time you load the terminal and run your zsh shell.

7
  • 22
    and it will also break all your non-interactive jobs (scp for example).
    – Jakuje
    Mar 11, 2016 at 16:45
  • 3
    Sorry for the downvote, but changing /etc/passwd or chsh are better solutions and more reliable.
    – Timo
    Dec 25, 2018 at 11:57
  • Thanks that did it. @Timo I did the change on /etc/passwd and or chsh but my default kept going back to bash. I added exec zsh as per posted response and it worked.
    – Stryker
    Feb 11, 2019 at 21:42
  • 1
    Adding exec zsh is most likely going to break your Gnome Shell session.
    – fracca
    Oct 26, 2019 at 10:58
  • This was the only one that worked for me on the work machine with active directory, my username is always not found, whoami works fine, but certain commands such as chsh always cannot locate my username
    – element11
    May 15, 2020 at 18:20
15

I had an issue with permissions to change shell under the current user but next helps me (you should set correct 'zsh' folder for your computer):

sudo chsh -s /bin/zsh <myUserName>
1
  • very helpful, thank you!
    – Rohan
    Feb 18, 2021 at 11:08
2

If zsh is not /bin/zsh then chsh won't work. On Ubuntu it is /usr/bin/zsh. so doing chsh -s /usr/bin/zsh or chsh -s `which zsh` should work. Also need to re-login to desktop session.

3
  • 1
    On my Ubuntu VPS it's /bin/zsh Dec 9, 2015 at 12:39
  • On my Ubuntu, I see it in both /bin/zsh and /usr/bin/zsh
    – blue_chip
    Apr 10, 2017 at 14:34
  • 2
    On mine (14.04, with zsh from main repo), there are two zsh's, and they are both two-layer symlinks: /usr/bin/zsh -> /etc/alternatives/zsh-usrbin -> /bin/zsh5 and /bin/zsh -> /etc/alternatives/zsh -> /bin/zsh5
    – wjandrea
    Oct 21, 2017 at 0:36
2

Strange, the "accepted" answer didn't work for me as I got

chsh: PAM: Authentication failure

To solve this issue edit your /etc/passwd and make sure it points to the zsh location. (You can find this by running "which zsh") In my case my user called "webmaster" looked like this:

webmaster:x:1001:1001:webmaster,,,:/var/www/webmaster:/usr/bin/zsh
2
  • I believe it's supposed to ask for a password. I got the same error on my previous mint install. Current one worked fine though Dec 9, 2015 at 12:40
  • Someone else had the same problem, and it turned out they had ran chsh -s zsh, which made their passwd entry incorrect.
    – wjandrea
    Oct 21, 2017 at 0:46
0

As well as chsh (or editing /etc/passwd, which does the same thing), you might need to edit the settings in your terminal emulator (Gnome terminal, Konsole, xfce4-terminal, etc). Your profile will probably have a login shell, which will be run when you open a new tab instead of the shell in /etc/passwd.
In Konqueror it's Settings | Edit Current Profile | Command.

Not the answer you're looking for? Browse other questions tagged or ask your own question.