0

I've been trying to install a tar.gz package (aalib-1.2) by extracting it and using a configuration command (./configure). This is what I got:

tabtes@Conrize:~$ cd ~/Downloads/aalib-1.2
tabtes@Conrize:~/Downloads/aalib-1.2$ ./configure
loading cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for working aclocal... missing
checking for working autoconf... missing
checking for working automake... missing
checking for working autoheader... missing
checking for working makeinfo... missing
checking whether make sets ${MAKE}... yes
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking host system type... Invalid configuration `x86_64-pc-linux-gnuoldld': machine `x86_64-pc' not recognized

checking for ranlib... ranlib
checking for non-GNU ld... /bin/ld
checking whether we are using GNU ld... yes
checking whether ln -s works... yes
ltconfig: you must specify a host type if you use `--no-verify'
Try `ltconfig --help' for more information.
configure: error: libtool configure failed

Here are also some other info regarding my Linux system:

OS: Ubuntu 20.10 x86_64
Host: HP ENVY x360 m6 Convertible 
Kernel: 5.8.0-43-generic 
Shell: bash 5.0.17 
DE: GNOME 3.38.2 
CPU: Intel i5-7200U (4) @ 3.100GHz 
GPU: Intel HD Graphics 620 
Memory: 7560MiB / 11850MiB

Update #1: Sorry that I wasn't clear on my situation. I'm very new with Linux and the community, so I would've expect to miss some important details. I'll update this page when needed. Right now, I've added some info regarding my Linux system.

5
  • Impossible to tell when you omit all the important parts. like what it is you try to compile, the command line options used , at least --no-verify was used as this is why it fails as you do not let the configure script do it job and to try detect it properly by using it. The output of ./configure --help would be nice as it gives the options that can be passed into the script. A link to the software in question to be able to look at the files it has for any other clues. Just off the top of my head what is needed to help trouble shoot this.
    – user1179897
    Feb 20, 2021 at 21:27
  • Dude next time give us all the methods ONE by ONE! Like I download this file X from website Y and I'm trying to do Z thing, my Operation System is A version B. Assuming you've an updated OS, I've tried steps S, D, F and G and got P as result. And please share us all important info, terminal and maybe some logs. Thanks! Feb 20, 2021 at 21:35
  • It looks like you're trying to install some program. A. it could be that your OS is incompatible, your configuration is wrong or not adjusted. B. Some tools are missing (and sometimes it's ok to have some errors, but some capabilities could be missing) C. Your problem seem easy to fix but WHEN we discover the problem first Feb 20, 2021 at 21:43
  • You can use the edit link under your post to add details. Include more information about the package/software that you are trying to install. Also include the exact steps or commands that you are using to reproduce your issue. Provide full, unredacted terminal output when applicable.
    – Nmath
    Feb 20, 2021 at 21:58
  • 1
    It looks like aalib-1.2 is over 20 years old... why do you believe you need to build this software? Feb 20, 2021 at 23:33

1 Answer 1

0

You should not compile such an old version.

Use binary deb-package from official repository instead:

sudo apt-get install libaa1-dev

and then start using it.

Also note that there is Python binding for it. Its package is named python3-aalib. You can install it with:

sudo apt-add-repository universe
sudo apt-get install python3-aalib
2
  • Thanks. Didn't know I was installing something old.
    – Tabtes
    Feb 21, 2021 at 17:56
  • If this answer helped, please mark it as accepted to indicate that problem is solved. Use repositories to install popular software.
    – N0rbert
    Feb 21, 2021 at 19:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.