3

on boot up it goes directly to the dreaded grub prompt

Ubuntu 20.04 was running fine ( /dev/sda5 ) until I deleted ( in gparted ) an unused partition /dev/sda6 which then automatically renamed the following partition /dev/sda7 to then be called /dev/sda6 (bug in gparted ? it should have left 7 as 7) ... box had a dual boot of fedora on what originally was /dev/sda7 also running fine until now

this is an old 2012 vintage laptop and I see no mention of UEFI in the bios ... I get following message when I run boot-repair

The current session is in BIOS-compatibility mode. Please disable BIOS-compatibility/CSM/Legacy mode in your UEFI firmware, and use this software from a live-CD (or live-USB) that is compatible with UEFI booting mode. For example, use a live-USB of Boot-Repair-Disk-64bit (www.sourceforge.net/p/boot-repair-cd), after making sure your BIOS is set up to boot USB in EFI mode. This will enable this feature.

https://paste.ubuntu.com/p/btw3GkGGqB/ any suggestions ?

currently I am booted up in live usb on this box with gparted showing

enter image description here

1 Answer 1

3

Try reinstalling GRUB from the LiveCD.

Drop to a terminal window and mount your sda5

mount /dev/sda5 /mnt

Then run the following to do a chroot to reinstall grub on the system:

for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
chroot /mnt

Then you should be at a $ prompt and see your Ubuntu installation. You should now be able to reinstall grub and update grub

sudo grub-install /dev/sda
sudo update-grub

After it is done, then type in exit and then reboot your system.

1
  • 1
    Brilliant ... spot on ... now its humming along nicely ... cheers Feb 20, 2021 at 18:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .