I am running Ubuntu 12.04 64bit dualbooting Windows 7. My issue is with my D'Link DWA 140 RangeBooster N Adapter.
Apparently it uses the RaLink chip.

lsmod | grep ^rt 


rt2800usb              22684  0  
rt2800lib              58925  1 rt2800usb   
rt2x00usb              20762  1 rt2800usb   
rt2x00lib              55301  3 rt2800usb,rt2800lib,rt2x00usb   

My proper speeds should be actual download speeds of 2.0 MB/s ( ISP provides me with a 20Mbps connection). With this driver in Ubuntu, I barely get speeds of 50 KB/s.
Even then, it will momentarily disconnect at an estimated interval of 5 to 10 seconds everytime.

I have tried this guide to install the RaLink driver:

The problem with that guide was, with my first install of Ubuntu 12.04 I lost all Internet connectivity. I am now on my second install of Ubuntu 12.04. I then tried this guide instead, I did every step:

I managed to get through the whole thing without a problem, however upon doing:

lsmod | grep -i rt2870  

It returned blank. I had no internet connectivity and it did not recognize my D'Link adapter.
I have internet connection now because I removed the previous blacklist of those modules, disconnected and then reconnected the adapter to get it using the old driver.

A strange thing that confuses me is that, Ubuntu uses rt2800 while others recommend using rt2870 yet when I do this:


I get this (truncated to show only relevant information):

Bus 001 Device 009: ID 07d1:3c0a D-Link System DWA-140 RangeBooster N Adapter(rev.B2) [Ralink RT3072]  

As you can see, it clearly says RT3072. I seriously have no clue what Ubuntu is or is not using in the background. I assume lsmod is telling me the truth. How can I fix this problem with my Internet connection? Its almost unusable. I wait for more than half an hour for it just to check if there are updates because the connection gets stuck in a state of temporary disconnection. It doesn't help that it cannot reach higher speeds than 50KB/s, and even thats rare.

This is not an issue with my adapter, as in Windows it works to its full potential. I have been having issues with this RaLink driver since 11.04. It's become so bad in 12.04 that I am pleading for help here.

I have now also tried setting my wireless connection via Edit Connections. Under the Wireless tab, I edit my wireless and set IPv6 Settings to Ignore instead of Automatic as I have read elsewhere this also helps. In my case, this does NOT help.

I have also set my Wireless Power Management off via:

sudo iwconfig wlan0 power off  

This does switch off power management, but even this step does NOT help my connection from constantly speeding up one moment and dropping the next. I am getting really frustrated. I hope someone can guide me, or at least give me a tip that helped them previously regardless of hardware differences.


I had the same problem and I found the solution on the official French Ubuntu forum:

Go to Ralinktech and download "RT8070 /RT3070 /RT3370 /RT5370 /RT5372 USB". Extract it (twice) and you should have:


Open it, open the "os" folder and then the "linux" folder. Open "config.mk" with a text editor (gedit, nano or vim) and modify the following lines swapping "=n" to "=y".

# Support Wpa_Supplicant

# Support Native WpaSupplicant for Network Maganger

Save and close. Then using the console :

sudo apt-get install build-essential
cd ~/Downloads/2011_0719_RT3070_RT3370_RT5370_RT5372_Linux_STA_V2.5.0.3_DPO
sudo make install

Plug in the USB and reboot.


  • Thank you very much Galerien. Just to further add, before I got the rt5370sta working independently I had to remove the rt2800usb rt2800lib rt2x00usb and rt2x00lib modules. Then replug in the USB adapter, and it works. I really can't thank you enough man. – Yusuf Ismail May 8 '12 at 23:35

I followed the same steps. However, the rt5370sta module does not support all DWA-140 B1 devices, believe it or not.

My devices product id is 3c09. Thus when I install the module rt5370 is not loaded.

I have modified the files:

  1. /os/linux/rt5370sta.mod.c
  2. /common/rtusb_dev_id.c

In (1) I searched for 07D1 and after the following:

MODULE_ALIAS("usb:v07D1p3C0F .... 

I added the exact same line but with 3C09 instead of 3C0F.

In (2) I also searched for 07D1 (you can see where this is going) and copied one of the lines which contained 0x07D1,0x3C0 and changed it to 0x3C09.

The same steps were then followed (sudo make & sudo make install).

Now whenever I plug it in rt5370 is loaded and after a reboot it works wonderfully.


Following the instructions of Galerien, I could install the driver rt5370sta.

Two solutions:

Solution 1:

I needed to use sudo make instead make, because I had got a permission problem. After this, the compilation was OK.

I did reboot but the problem still was there. The difference was that now the grep | ^rt showed:

rt5370sta             450556  0 
rt2800usb              18235  0 
rt2800lib              45181  1 rt2800usb
rt2x00usb              20330  1 rt2800usb
rt2x00lib              49235  3 rt2800usb,rt2800lib,rt2x00usb

Then used this

sudo modprobe -rf rt5370sta rt2800usb rt2800lib rt2x00usb rt2x00lib

and this

sudo modprobe rt5370sta

NOTE: The second method is an adaptation of the answer to another problem with DWA-140 that found before (and didn't worked to me with rt2870sta). To finish the operation, I've "blacklisted" the rt28x...'s like says in the other link.

And now it works fine, the wifi recovered the speed.

Solution 2

I updated the kernel to 3.2.0-24-generic and got back the same problems. But, I've done the installation of rt5370sta (just following the Galerien's instructions again) and it works fine again.

Not needed to blacklist the others rt28x, it doesn't load any rt28x..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.