0

I am facing lots of issues on kernel 5.4 so I decided to update to kernel 5.8.10.

I am getting the following error message: error message

I am using Ubuntu 18.04.5 with lenovo bios 1.10 , secure boot disabled.

0

You’ll likely need to update the GRUB_CMDLINE_LINUX_DEFAULT in your /etc/default/grub file to include iommu=pt. If you cannot boot normally, you may need a Live USB to make this work.

  1. Edit the Grub boot file as root:
    sudo vi /etc/default/grub
    
  2. Add the iommu flag to GRUB_CMDLINE_LINUX_DEFAULT so that you have something like:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash iommu=pt"
    
  3. Save the file
  4. Run the Grub updater. This is very important. Do not forget:
    sudo update-grub
    
  5. Reboot

This should resolve the issue.

3
  • I have a question about the live USB part. Do I need to use a live usb or can I use my working 5.4 kernel to modify and update the grub file? – concorde42 Feb 19 at 6:52
  • If the 5.4 kernel option is working, that will require fewer steps 👍🏻 – user1091774 Feb 19 at 6:59
  • I modified the grub file and ran grub update. I am still getting the same error when I boot to kernel 5.8.10 – concorde42 Feb 19 at 7:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.