I found out it is possible to run ubuntu on a USB. So thats what i tried and it worked. I wanted to test an express application but installing node js throws an error everytime.

sudo apt install nodejs
sudo apt install Nodejs

Error: E: Paket nodejs kann nicht gefunden werden. (German for "Package not found")

since today my only experience with linux was a 5€ a month server i bought and played around with

Note: Any tipps for asking better questions in the future?

  • 1
    I did a apt-cache search node|grep js and it comes up with heaps of possible packages that you could mean, you need to be exact (including case) If you don't know commands you can still use browser tools (packages.ubuntu.com/…)
    – guiverc
    Feb 19, 2021 at 2:47
  • You'll need the universe repository enabled and updated, then your first command should work. At least it appears to (with a -s) on a 20.04 fairly stock install. Do you have the universe repository enabled?
    – KGIII
    Feb 19, 2021 at 2:51
  • 1. Thx for the answers i dont know what a universe repo is. 2. i tried the same command and the terminal gave me nothing. I left the |grep part out and the terminal just threw a lot of things at me (i assume these are packages) but yeah "node" is a fairly often used word in programming so i assume these things go hand in hand. when i do the same with "nodejs" it gives me a package called "autodep-8
    – Venox
    Feb 19, 2021 at 2:57


Browse other questions tagged or ask your own question.