0

I've recently noticed that in the file bar/explorer filesystem root and efi shown as external HDD. It is kind of weird I don't know it does affect the system processes or not. Furthermore, usb drives are not shown up, but I run lsusb command i can see that usb drive is connected. Any insight or help are appreciated

The output of fdisk -l:

Disk /dev/loop0: 218.102 MiB, 229629952 bytes, 448496 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop1: 97.9 MiB, 102637568 bytes, 200464 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop2: 98.36 MiB, 103129088 bytes, 201424 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop3: 55.48 MiB, 58159104 bytes, 113592 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop4: 31.9 MiB, 32600064 bytes, 63672 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop5: 162.89 MiB, 170778624 bytes, 333552 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop6: 51.4 MiB, 53522432 bytes, 104536 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop7: 217.92 MiB, 228478976 bytes, 446248 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/sda: 931.53 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: TOSHIBA MQ01ABD1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: EC7C0DD1-5B5C-49CE-8C81-483CDB4FEAB4

Device Start End Sectors Size Type
/dev/sda1 2048 1050623 1048576 512M EFI System
/dev/sda2 1050624 1953523711 1952473088 931G Linux filesystem




Disk /dev/loop8: 51.2 MiB, 53501952 bytes, 104496 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop9: 64.36 MiB, 67477504 bytes, 131792 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop10: 64.79 MiB, 67915776 bytes, 132648 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop11: 31.9 MiB, 32595968 bytes, 63664 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop12: 172.99 MiB, 181366784 bytes, 354232 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop13: 129.10 MiB, 136286208 bytes, 266184 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop14: 149.76 MiB, 157016064 bytes, 306672 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop15: 55.39 MiB, 58073088 bytes, 113424 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop16: 149.76 MiB, 157016064 bytes, 306672 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes 

Output of blkid:

/dev/sda2: UUID="f3023789-28b0-4138-b6c8-6c10b8219ca2" TYPE="ext4" PARTUUID="99b4c4fc-3a52-435a-a601-ae10cb06371c"
/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/loop3: TYPE="squashfs"
/dev/loop4: TYPE="squashfs"
/dev/loop5: TYPE="squashfs"
/dev/loop6: TYPE="squashfs"
/dev/loop7: TYPE="squashfs"
/dev/sda1: UUID="B04C-7CC4" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="ab146d04-bfae-4c6f-8b7f-9d8b3607fcb3"
/dev/loop8: TYPE="squashfs"
/dev/loop9: TYPE="squashfs"
/dev/loop10: TYPE="squashfs"
/dev/loop11: TYPE="squashfs"
/dev/loop12: TYPE="squashfs"
/dev/loop13: TYPE="squashfs"
/dev/loop14: TYPE="squashfs"
/dev/loop15: TYPE="squashfs"
/dev/loop16: TYPE="squashfs"
/dev/sdb1: LABEL="emil" UUID="926B-0C3A" TYPE="vfat" PARTUUID="4668a8dd-01"

The last line is my usb driver name but somehow it does not show up in file explorer. Filesystem root and efi are recognized as external HDD.

0
/dev/sda1 2048 1050623 1048576 512M EFI System
/dev/sda2 1050624 1953523711 1952473088 931G Linux filesystem

These are not external disks.

These are partitions 1 and 2 on the internal disk /dev/sda.

The EFI partition (typically formatted to FAT32) and the root filesystem (/) (most typically formatted to ext4) belong on their own partitions as you see them. That's normal and no grounds for performance concerns — especially if they were set up so by the installer.

The naming of the internal disk, /dev/sda also suggests that it's the first and primary one of such devices, that's why it's designated with a, the first letter of the alphabet.

Your system is actually more integrated / less distributed across various partitions than of many others'. In Ubuntu land it's a common practice to introduce the /home/user directory to its own dedicated partition. But your system is not set up such way: your OS and user files are on the same partition.


File managers make a sharp distinction between the directories / files of the user (/home/<username>) and the directories / files of the operating system ('/').

When opened, they show you your user files by default. Accessing the operating system's directories needs some additional, out-of-pattern navigation.

This was perhaps done to

  • make things appear more simple for non-power-user people
  • protect the system directories from people who would not know how to handle them

It's a bit misleading though that the file manager uses the "disk" icon not only to represent disks AND partitions, but also to visualize this distinction / division between user directories / and OS directories.


Regarding the USB device not showing up, you can try querying these settings regarding automatic mounting of removable media (return values are either true or false):

gsettings get org.gnome.desktop.media-handling automount

(description: "If set to true, then Nautilus will automatically mount media such as user-visible hard disks and removable media on start-up and media insertion.")

and

gsettings get org.gnome.desktop.media-handling automount-open

(description: If set to true, then Nautilus will automatically open a folder when media is automounted. This only applies to media where no known x-content/* type was detected; for media where a known x-content type is detected, the user configurable action will be taken instead.)

If you find that you need to change any of these settings, you can do so according to the following pattern:

gsettings set org.gnome.desktop.media-handling automount true

If you want to explore and manage these settings on a graphical interface, you can install the dconf-editor app.


If the auto-mounting settings don't improve the situation with the USB, you could try mounting it manually in the terminal.

Even if the manual mount fails, it at least could provide useful feedback / insight into what may be the issue with the USB.

4
  • I've executed those above 2 commands gsettings get org.gnome.desktop.media-handling automount and gsettings get org.gnome.desktop.media-handling automount-open. Both returned true but still does not shown up when I plug the usb driver in. I checked usb driver in windows machine it totally works fine. No issue with usb driver
    – Emil
    Feb 18 at 13:36
  • @Emil I don't know whether it has to do with that the device is formatted to "vfat"...? (FAT16 or FAT32?). Does your disk contain any important data on it now? Would you consider re-formatting?
    – Levente
    Feb 18 at 13:51
  • @Emil you could try mounting manually in the terminal: askubuntu.com/a/37775/1157519 If it does not succeed, at least it will tell you something useful about why not. Then you could edit your question and append that info there.
    – Levente
    Feb 18 at 13:55
  • If accessing via terminal is not successful I would consider re-formatting. I have back up fortunately. Thanks for the feedbacks
    – Emil
    Feb 18 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.