1

I have some problem installing Maya 2020 on Ubuntu 20.04. While Maya installed, there was a problem with the license and upgrade in the console. What is going on? When tries to run Maya won't start. When trying to start from the console with the command:

/usr/autodesk/maya2020/bin/maya

I see something like this:

A licensing error occurred that Autodesk systems were not able to handle for you. Please contact Autodesk Customer Support for help in resolving this error.
adlsdkAuthorize returned with error code: ADLSDK_STATUS_ADLS_NOT_FOUND
The default location for log files to help diagnose the issue is: /usr/tmp

Interestingly, the path /opt/Autodesk/AdskLicensingService does not exist! Even though I did everything they wrote on the Autodesk website! When I wanted to fix it somehow, I damaged something. With sudo apt-get upgrade I see something like this (the console will be in Polish):

Czytanie list pakietów… Gotowe
Budowanie drzewa zależności
Odczyt informacji o stanie… Gotowe
Należy uruchomić “apt --fix-broken install”, aby je naprawić.
Następujące pakiety mają niespełnione zależności:
libc6 : Poleca: libnss-nis ale nie da się go zainstalować
Poleca: libnss-nisplus ale nie da się go zainstalować
Narusza zależności: libc6:i386 (!= 2.31-9) ale 2.31-0ubuntu9.2 jest zainstalowany
libc6:i386 : Narusza zależności: libc6 (!= 2.31-0ubuntu9.2) ale 2.31-9 jest zainstalowany
libc6-dbg : Wymaga: libc6 (= 2.31-0ubuntu9.2) ale 2.31-9 jest zainstalowany
libc6-dev : Wymaga: libc6 (= 2.31-0ubuntu9.2) ale 2.31-9 jest zainstalowany
libc6-i386 : Wymaga: libc6 (= 2.31-0ubuntu9.2) ale 2.31-9 jest zainstalowany
E: Niespełnione zależności. Proszę spróbować wykonać “apt --fix-broken install” bez pakietów (lub podać rozwiązanie).

I will mention right away that I was doing apt --fix-broken install but this message pops up every time. Please help. Thank you in advance.

2
  • Why not do what it says right in your question? Please contact Autodesk Customer Support for help in resolving this error
    – David
    Feb 18 at 7:28
  • Ubuntu is not on the list of supported operating systems for Autodesk Maya 2020
    – BulletBob
    Feb 18 at 8:24
1

the "official" instructions for installing maya on ubuntu is here: https://knowledge.autodesk.com/support/maya/learn-explore/caas/simplecontent/content/installing-maya-2020-ubuntu.html

considering the path /opt/Autodesk/AdskLicensingService does not exist on your install perhaps the missing steps for you are the following(shamelessly copy pasted)

install the licensing packages: adlmapps, adlmflexnetserveripv6, adlmflexnetclient, and adsklicensing.
Verify that the licensing service is running.

    sudo systemctl status adsklicensing

If the licensing service is not running:
 

    Start it using this command:

    /opt/Autodesk/AdskLicensingService --run
    
    Verify again that the service is running.
     
If it is still not running, set up the licensing service manually:

    sudo getent group adsklic &>/dev/null || sudo groupadd adsklic
    sudo id -u adsklic &>/dev/null || sudo useradd -M -r -g adsklic adsklic -d / -s /usr/sbin/nologin  
    sudo ln -sf /opt/Autodesk/AdskLicensing/9.2.1.2399/AdskLicensingService/AdskLicensingService /usr/bin/AdskLicensingService
    sudo mkdir /usr/lib/systemd/system
    sudo cp -f /opt/Autodesk/AdskLicensing/9.2.1.2399/AdskLicensingService/adsklicensing.el7.service /usr/lib/systemd/system/adsklicensing.service
    sudo chmod 644 /usr/lib/systemd/system/adsklicensing.service
    sudo systemctl daemon-reload
    sudo systemctl enable adsklicensing –quiet
    sudo systemctl start adsklicensing

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.