1

I have newly installed Ubuntu 20.04.2.0 LTS on my laptop (Asus Zephyrus G15, AMD 5900HS, Nvidia 3070). Two major issues I'm having trouble fixing:

  1. Neither the brightness slider in ubuntu nor the brightness Fn keys on my keyboard work, the brightness does not change at all.
  2. The sound slider in ubuntu and the volume keys on my keyboard do produce the default "beep" sound whenever volume is adjusted, however, the volume stays constant and does not actually change (except mute).

I tried changing one line in the bootloader file to each of the following, then ran sudo update-grub and rebooted:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=native"

Neither option worked.

I tried following this guide to install Nvidia drivers. However, unlike in the guide, my software & updates does not show any available updates for Nvidia: Software Updates Following the second method in the guide of using command line to update Nvidia drivers, I typed into the command line:

ubuntu-drivers devices

and got no output.

Some posts also mentioned that ubuntu drivers has issues with secure boot. I have also disabled secure boot from bios, and it did not change anything.

I also tried checking which graphics card ubuntu is actually using following this thread. By typing this in the command line:

lspci -vnnn | perl -lne 'print if /^\d+\:.+(\[\S+\:\S+\])/' | grep VGA

I got the following output:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:249d] (rev a1) (prog-if 00 [VGA controller])
06:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:1638] (rev c4) (prog-if 00 [VGA controller])

I'm not sure how to interpret this, does this mean the system is indeed using NVIDIA GPU?

I have not yet tried any solution for the volume control problem as I can't seem to find anyone else with similar problems.

2
  • I am in the same boat as you. As far as I know is that the drivers for the amdgpu or nvidia don't work yet. I had to blacklist noveua - the open source nvidia driver just to not run into a black screen. Also it seems that by default is used both the nvidia funneld through the amd gpu - that explains the low battery life and constant fan. I am going to watch your thread and if I find anything out post here. – flyandi Feb 24 at 7:45
  • One more thing - the Spanish vendor Slimbook just released their Titan with similar specs to the G15 - I have not seen anything on their GitHub - but I am watching them - at one point they will update the amd gpu drivers – flyandi Feb 24 at 7:49
1

So check it out - I got it all working except it didn't work. The reason is that Nvidia has not released their drivers with 30x series Laptop GPU support yet. I found it by using nvidia-smi to check for the GPU and while it identifies it still says "unsupported device in driver tree".

Also AMD has not updated the Vega driver for the 5900HS .. and also thinks that my CPU is a 5900HX ...

So welcome living on the bleeding edge :-D We just have to wait for a bit to get those drivers and it will all work. Also https://gitlab.com/asus-linux/asus-nb-ctrl works for all the fan stuff (that works without anything else).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.