0

I have a USB wifi dongle that I am trying to use with an old HP tower that I installed Ubuntu 20.04 on (light install).

lsusb shows: Realtek Semiconductor Corp. USB3.0 802.11ac 1200M Adapter for the device in question. It shipped with a Windows version of a RTL8812BU driver. There are also Linux drivers available on the manufacturer website (http://www.wise-tiger.com/English/html/2731985548.html).

I tested the dongle on a laptop running 16.04 and got it to work using the manufacturer-provided driver with only minor difficulty.

The drivers are outdated, but I manually patched them for 20.04 and the installer seems to run fine now, but I still don't see wifi networks available.

I realize there are numerous similar questions, so I've tried solutions from those. The most promising seemed to be getting the driver from here: https://github.com/morrownr/88x2bu. I followed those instructions without error, but still got no wifi connection after a reboot.

When I look at Settings > Network there isn't even an option for wireless.

ifconfig output:

eno1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.10  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::3350:e196:1b67:13b2  prefixlen 64  scopeid 0x20<link>
        ether 74:46:a0:9b:5d:33  txqueuelen 1000  (Ethernet)
        RX packets 34152  bytes 15533511 (15.5 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 16952  bytes 2227272 (2.2 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 20  memory 0xf7c00000-f7c20000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 3110  bytes 313665 (313.6 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 3110  bytes 313665 (313.6 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

iwconfig:

lo        no wireless extensions.

eno1      no wireless extensions.

lshw -C network:

  *-network                 
       description: Ethernet interface
       product: 82579LM Gigabit Network Connection (Lewisville)
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: eno1
       version: 04
       serial: 74:46:a0:9b:5d:33
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k duplex=full firmware=0.13-4 ip=192.168.0.10 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:25 memory:f7c00000-f7c1ffff memory:f7c39000-f7c39fff ioport:f080(size=32)

(wired works fine).

rfkill list returns no output.

Not seeing wlan0 or something equivalent at all seems odd to me. Any new ideas welcome.

1

You can install drivers from Cilynx's GitHub repo for RTL88x2BU that has worked well for me.

As detailed in the repo, I've installed the drivers using DKMS installation method:

git clone https://github.com/cilynx/rtl88x2bu.git
cd rtl88x2bu
VER=$(sed -n 's/\PACKAGE_VERSION="\(.*\)"/\1/p' dkms.conf)
sudo rsync -rvhP ./ /usr/src/rtl88x2bu-${VER}
sudo dkms add -m rtl88x2bu -v ${VER}
sudo dkms build -m rtl88x2bu -v ${VER}
sudo dkms install -m rtl88x2bu -v ${VER}
sudo modprobe 88x2bu
3
  • Thanks for the suggestion. I tried, this but same outcome as the other drivers I've tried. I still don't see any options to even attempt a wifi connection. I think my issue must be elsewhere in configuration since all these drivers appear to install just fine. – Max Poschmann Feb 19 at 14:25
  • @max-poschmann what's the Device ID you get when you run lsusb. In my case it's 2357:012d, and full string looks like: Bus 001 Device 003: ID 2357:012d TP-Link Archer T3U [Realtek RTL8812BU]. Thanks. – Jags Feb 19 at 16:42
  • 0bda:b812. I looked here: deviwiki.com/wiki/0bda and it says "Realtek RTL8812BU Wireless 802.11ac 2x2 USB 3.0". Thus I think I have been using the correct driver version. This is further corroborated by me using that driver version successfully on 3 other machines. – Max Poschmann Feb 22 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.