0

I'm using ssh from Windows 10 and connecting to remote Ubuntu server works well.

but when I tried to copy a local file in Windows10 to an Ubuntu server, using scp:

scp -P [port number] [source path] [remoteUsername@remoteIP:/Some/Path]

after I put the password, it gets stuck forever(pw is correct).

It doesn't show anything.

I tried using pscp, but it shows exactly the same problem.

I also tried running command prompt with 'run as an administrator' in Windows 10, but the same result.

What should I do?

2
  • Are you using scp from WSL to an external Ubuntu server? Or is this the Windows version of scp that you're using?
    – user1091774
    Feb 17 at 5:29
  • @Matigo I think the Ubuntu server somehow blocked incoming scp(It's not my own server). I'm not sure if this is a "Windows version", but yeah I used scp in Windows10 (scp is built-in in Windows 10). After I found that it doesn't work, I installed putty and pscp and tried again, which also failed. I guess a server can block the scp connection, right?
    – starriet
    Feb 17 at 14:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.