16

Upgrading to 12.04 caused some problems to my Firefox. It seems like that Firefox doesn't know how to handle downloads.

After some researches, I've found this solution : Kubuntu 12.04 Firefox and Rekong don't know how to open downloaded files

but it still doesn't work as it should, in fact it opens my mp3 with Audacity and not with the default player.

But the worst thing is that "Open folder" opens Gwenview instead of Dolphin!

Suggestions?

19

On Kde, a different approach not involving direct editing. Took it from the link Miguel Aguayo gave in his answer. Someone attached that answer at the bottom in 2014.

  1. Go to System Settings.
  2. Open File Associations.
  3. Go to Inode -> Directory
  4. Remove Gwenview from the Application preference order list. Press Apply.
  5. Optionally, you can add again Gwenview and make it at the bottom of the list of preferences.
  • +1 for using UI instead of editing files. This worked for me even though Gwenview was initially already last option. Removing it fixed Firefox and adding it back did not break it. – Piotr Findeisen Mar 10 '15 at 21:03
  • 1
    This issue is still relevant in Kubuntu 14.10 and the answer still works so thanks @elpd. – DazBaldwin Apr 16 '15 at 12:28
  • Still relevant in Kubuntu 15.04, and still works. – dr. Sybren Jun 22 '15 at 13:41
  • also relevant in Kubuntu 18.04, it worked for me and also Gwenview was already last option. – mmttato Dec 1 '18 at 22:30
  • Also relevant for XFCE4 where Firefox was using VSCode to open folder instead of Thunar – Tushar Tyagi Dec 15 '18 at 17:11
4

This link worked for me.

In short, in the file /home/$USER/.local/share/applications/mimeapps.list add these lines:

[Added Associations]

x-directory/normal=kde4-dolphin.desktop;kde4-kfmclient_dir.desktop;
inode/directory=kde4-dolphin.desktop;kde4-kfmclient_dir.desktop;kde4-gwenview.desktop;kde4-filelight.desktop;kde4-cervisia.desktop;

[Default Applications]

inode/directory=kde4-dolphin.desktop;kde4-kfmclient_dir.desktop;kde4-gwenview.desktop;kde4-filelight.desktop;kde4-cervisia.desktop;
x-directory/normal=kde4-dolphin.desktop;kde4-kfmclient_dir.desktop;
4

I've also encountered this problem. Rather than copy-pasting a blob of text which I don't understand, I tried to figure out which parts of the suggested answer are useful.

  1. Edit the ~/.local/share/applications/mimeapps.list
  2. Append either of the following lines (at the [Added Associations] section):

    x-directory/normal=kde4-dolphin.desktop;
    inode/directory=kde4-dolphin.desktop;
    
  3. Save and Firefox will use Dolphin from now on.

You do not need both lines. Whichever comes last defines the file browser to be opened.

This configuration file maps a mime-type to a .desktop file, which defines which application ought to open the file. After the mime-type, a semicolon-separated list of possible applications is listed. The left-most application has the highest priority, the rightmost file has the lowest (fallback) priority.

Those *.desktop files are located at /usr/share/applications/.
The kde-*.desktop files are located at the subdirectory /usr/share/applications/kde4/.
( /usr/share/applications/kde4/dolphin.desktop , for example )

0

elpddev's answer was right but outdated.

If you use Kubuntu or Plasma desktop, open System Settings and open Applications under Personalization. Under Default Applications, click File Manager and select Files or any other file manager you want. You can here change default terminal too which was driving me nuts.

  • Tried this before looking for a solution on the internet. Dolphin was set as default but still did not fire up when I used the "open folder" option in transmission (the torrent client). – mmttato Dec 1 '18 at 22:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.