I'm running 12.04 inside VMWare Workstation.

What is wrong with my installation so that I cannot resize the window at the lower right corner? The lower left does work, albeit it's really hard to get it; upper left/right works OK, see this video:


Just to make it clear: this is not restricted to terminal, same with Firefox, synaptic, etc.


7 Answers 7


I have exactly the same issue, also running Ubuntu 12.04 in a VMware virtual machine. It's the same using VMware Fusion and VMware ESXi. It is also extremely difficult to grab any window edge, for example, to stretch the window horizontally or vertically.

The only solution I have found so far is to use the shortcut of holding down ALT and using the third button (usually middle) on the mouse if you have one. This will allow the window to be resized while the pointer is within that window's boundary, bypassing the need to grab the lower-right corner.

  • 1
    lol, hilarious. Never heard about this way, absolutely useful because you don't need to grab anything small or so. Thanks a lot.
    – mark
    Commented May 29, 2012 at 21:54

I have found a few methods to solve this.

First, right clicking the title bar gives you a menu with re-size in it. Then whichever corner your pointer is closest to becomes a re-size handle which you then left click to end. This method only lets you be closest to the upper left and right corners however.

So... if you instead, use alt and a right click in the window, again you get a menu, but this way you can begin in the lower left or lower right of the window and then whichever you were closest to becomes the re-size handle. Then you re-size until satisfied, and then left click to release and keep the new size.

And lastly, since this menu show that alt-F8 is a shortcut, place the mouse pointer in the window closest to the corner you wish to re-size from and type alt-F8. When you release the keys, the mouse pointer will attach to the corner and you can re-size. Again, left click to end.


There is a bug report for the fact that on Unity 2D (which I think is being run in the video, and may be the only option in VMWare) the borders are very thin and difficult to grab, though why you should see this particularly on that corner I don't know.


There is a workaround in comment #8. It may be that will fix the problem here.

  • Adding a copy of the text from the link, which worked nicely for me: Another workaround is to hack the theme itself. For the Ambiance theme edit /usr/share/themes/Ambiance/metacity-1/metacity-theme-1.xml and in the section starting <frame_geometry name="frame_geometry_normal" change left_width, right_width and bottom_height from 1 to 3. I have not tried it on the Radiance theme but I expect the same change would work there. Keep a note of what you have done as if the theme is updated you might have to do it again. Commented Jun 24, 2015 at 23:14

I have the same problem on default setup (just installed gnome-session-fallback) under VMware Player with Windows host OS.

The alt+middle click trick works. You can also resize on upper-left window corner.


My problem was that the resize action was disabled in my compiz configuration. I solved it using Unable to resize windows

  • For me, when opening the CCSM, the setting was actually checked, but I unchecked it, and then checked it again, and voila!, it works. Stupid stuff.
    – stolsvik
    Commented Apr 16, 2013 at 11:44

If you have been tweaking around with Compiz, this could have caused the problem. If not, login in with gnome classic, and see if it still has the same problem.

  • I don't remember any tweaking; I also tested this with the guest account which I never used before, i.e. clean home directory with no old preferences.
    – mark
    Commented May 5, 2012 at 21:53
  • Did you try to log in with Gnome Classic? Commented May 5, 2012 at 22:07
  • how? On the login screen I can only choose "Ubuntu" and "Ubuntu 2D" (tried both)
    – mark
    Commented May 5, 2012 at 22:11
  • This is an extremely strange bug. Updating your distro (Press Alt-F2 and type update-manager -d) might help. If it doesn't, any thoughts on re-installing ubuntu? I know it sounds like a pain, but a clean 12.04 installation will very likely help. Commented May 5, 2012 at 22:18
  • thanks for the help so far. I'm running inside VMWare and I get the impression that it is maybe due this. I've also asked another question asked which hints me in the same problematic origin: askubuntu.com/questions/132348/… .
    – mark
    Commented May 5, 2012 at 22:42

I am using Ubuntu on an ACER netbook, and Alt+F8 or right clicking the title bar weren't working for me. I didn't have a third mouse button but was able to shift the window up by using Alt+ double tap on my touch pad.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .