0

I am new to Linux and Ubuntu and I recently installed a fresh copy of Ubuntu 20.04 LTS on virtualbox, it did a few updates during the OS installation. After the install, I restarted and checked for software updates, via the software updater, and I'm not exactly sure on the app to update, but I think it was an update for Ubuntu base, but before the update could complete, my internet disconnected, and the software updater said everything is up to date.

As I said I'm new to Ubuntu, tried going through the log files, but can't find anything that makes sense, and googling the problem I found some solutions like purging and reinstalling but am unsure on how to proceed, any assistance would be greatly appreciated

*edit

~$ sudo apt update
Hit:1 http://za.archive.ubuntu.com/ubuntu focal InRelease
Hit:2 http://za.archive.ubuntu.com/ubuntu focal-updates InRelease
Hit:3 http://za.archive.ubuntu.com/ubuntu focal-backports InRelease
Get:4 http://security.ubuntu.com/ubuntu focal-security InRelease [109 kB]
Fetched 109 kB in 4s (25.4 kB/s)
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.

~$ sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

2
  • What's the symptom? Is it broken? Does it start?
    – Levente
    Feb 13, 2021 at 19:30
  • Everything works fine, however the progress bar on the software updater didn't complete. And it threw out an error to say that the internet disconnected Feb 13, 2021 at 19:42

1 Answer 1

1

Software updates on Ubuntu work such way that the first half of the progress bar is just for downloading.

The second half is the actual writing to disk and configuring.

I will assume (based on personal experience) that if the network connection got interrupted during the download phase, it never got into the installation phase. There were no changes to the disk, and no bad consequences.

You are free to attempt the update again, by summoning the Updater app. If it still says everything is up to date, give it a reboot and try the Updater once more.

Bonus:

When you see the updater progress-bar, there should be some small widget around the bottom, or corner of that small window: it should say something like "See details" If you click that, you will see exactly what is happening when.

8
  • Well-reasoned and insightful.
    – user535733
    Feb 13, 2021 at 20:03
  • Thanks for the advice, I read up on the packages being downloaded before installation. Restarted and tried again, it says everything is up to date. Feb 13, 2021 at 20:43
  • @DarrynJacobs And you still have the suspicion that there was stuff that did not install properly? Because your system does not confirm that. I think it's totally o.k. to relax about it. I guess you will not be convinced until the next time it finds updates; but it will happen; probably in the following days (depending on your Updater settings.)
    – Levente
    Feb 13, 2021 at 20:48
  • @Levente My concern is I tried upgrading from 18.04 to 20.04 yesterday, when I came to the laptop, everything was finished, I restarted but my Ubuntu was still on 18.04 and the software updater kept on saying everything is up to date. And to your original question, everything on the OS operated fine as far as I could tell but obviously it wasn't up to date. So might be a different problem and cause, but in this case I'm worried about something being corrupted as I never physically saw the progress bar finish before the window exited. Feb 13, 2021 at 20:52
  • @DarrynJacobs This is new info. Your original post does not mention 18.04 at all. In fact, you wrote "I recently installed a fresh copy of Ubuntu 20.04 LTS". Anyways, I would edit the original question and put this info in there too.
    – Levente
    Feb 13, 2021 at 20:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.