1

I'm following instructions on the following page to the letter: https://ubuntu.com/download/kvm . When I run the kvm command, the VM screen appears containing the following error: error: no such device: ubuntu-boot, then GRUB screen shows, then (after choosing the default Install option) a blank screen with:

error: invalid signature.

Press any key to continue...

Then it returns to GRUB screen again. No options get me anywhere.

The sha256sum output of compressed image verifies with one provided on the page. Unfortunately, no checksum for uncompressed image is provided, so I'm unable to verify it (BTW, it is c8472b8fbeb72f677733606e77c4a87ac7937919b66be614abc42166cbae77c9). But I tried two different host systems (18.04, 20.04) and two decompressors (unxz, pixz), all with the same result. I also tried replacing kvm with qemu-system-x86_64, nothing changes.

2
  • Silly question, but do you have OVMF installed? Ubuntu Core dies not support BIOS boot methods, which is usually when this message is seen 🤔
    – user1091774
    Feb 13, 2021 at 13:11
  • Thank you for the suggestion. I do have ovmf package installed, but I don't understand how should I use it in this case. Running qemu with -L help shows three options, but neither of them changes much.
    – qm2k
    Feb 15, 2021 at 19:01

1 Answer 1

1

Had the same issue. This ended up working for me:

virt-install --connect qemu:///session --name core20 --memory 2048 --vcpus 2 \
--boot uefi --os-variant ubuntu20.04 --video virtio --graphics spice \
--import --disk path=core20.img,format=raw
1
  • Nice to know. I'd still be nice to know a bare-qemu solution.
    – qm2k
    Mar 7, 2021 at 17:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.