4

I need to use the Sony WH-1000XM3 bluetooth headset as output and input device for web calls / webinars (mostly zoom). Currently I manage to use it as output device with the "High Fidelity Playback (A2DP Sink)" configuration. My understanding is that I need to get "aptX/LDAC" running for example with installing this: ppa:berglh/pulseaudio-a2dp. I spent hours searching the answer in this forum and in other places and tried different solutions. So far the only effect was that I couldn't even use the headphones as output device any longer. Amongst the things I tried:

When I open the bluetooth devices manager (after installing the ppa mentioned above) and right-click on the WH-1000XM3 device and go to "Audio Profile" it shows me a selection of seven options: "headset_head_unit (HSP/HFP)", "High Fidelity Playback (A2Dp Sink: -a2dp_sink_sbc / -a2dp_sink_aac / -a2dp_sink_aptx / -a2dp_sink_aptx_hd / -a2dp_sink_ldac" or "Off". Whatever audio profile I choose it always results in the following error: "Failed to change profile to a2dp_sink_ldac"

So far my conclusion is that it is impossible to use the Sony WH-1000XM3 under Ubuntu 20.04. Is there any option left / something I haven't tried to fix this issue?

Regards K

6
  • This profile does not work?
    – David
    Feb 12, 2021 at 13:13
  • Which profile are you referring to? After re-installing pulseaudio (sudo apt install --reinstall pulseaudio pulseaudio-module-bluetooth) and rebooting, the profile/configuration that I can choose (in the Sound Settings / pavucontrol) is "High Fidelity Playback (A2DP Sink)" without _LDAC or _aptx etc. at the end. With this profile I can use my headphones as output device but not as input device. Or I install from the ppa mentioned the codecs, then nothing works at all. It offers me to choose from the LDAC/APTX/AAC codecs (in the bluetooth devices manager) but when I choose an error occurs.
    – kayB
    Feb 12, 2021 at 15:04
  • (HSP/HFP) oops I guess I forgot to paste. Sorry about that.
    – David
    Feb 12, 2021 at 15:08
  • No worries, I am happy about every hint. When I change the configuration in the sound settings to "Headset Head Unit (HSP/HFP)" the "Output Device" get set back to "Digital Output (S/PDIF) - Starship/Matisse HD Audio Controller" and as "Input Device" I can choose the WH-100XM3 Headset, but when I close the settings and open them again the drop down for "Input Device" is empty again, so it is not really selected. Similar in "pavucontrol": I can choose HSP/HFP in configuration but "Input Devices" is still empty ("No input devices available").
    – kayB
    Feb 12, 2021 at 15:18
  • I had the same problem here is the answer I got askubuntu.com/questions/1280768/mono-only-blurtooth-headset it is quite a long answer
    – David
    Feb 12, 2021 at 15:38

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy