I have a problem when I send my files from phone to ubuntu 12.04 via bluetooth as the phone prompts with the message "the file not sent"! I can send any files from ubuntu 12.04 to my android phone.


4 Answers 4


Go to Dash Home search for personal file sharing. If you don't have Unity installed, you can open the program from a terminal with typing gnome-file-share-properties in it.

Ubuntu Personal File Sharing Bluetooth

At the bottom of the box enable Receive files in downloads folder over bluetooth also enable Notify about received file then you're good to go :)

Personal File Sharing Application Ubuntu Bluetooth Sharing

  • 7
    How is the program name if I want to start that in a Terminal?
    – BuZZ-dEE
    Dec 18, 2012 at 18:59
  • 7
    gnome-file-share-properties Jun 18, 2013 at 8:09
  • 7
    this did not work for me on 64 bit Ubuntu 14.04
    – faizal
    Jul 12, 2014 at 15:21
  • 1
    Its worked for me on 32 bit Ubuntu 14.04. but didn't seen any notifications may be some error. Aug 25, 2014 at 1:44
  • 1
    It only worked after rebooting both smartphone and computer (I'm on Ubuntu 14.04 64 bit) @faizal
    – chelder
    Mar 13, 2015 at 15:08

[Updated answer tested on Ubuntu 20.04]

I have found that simply installing blueman and using the blueman applet works well:

  1. First, pair your device using the system default bluetooth menu.

  2. Install blueman:

    sudo apt-get install blueman
  3. Run the applet:

  4. Click on the new bluetooth applet indicator and select Local Services from the menu.

  5. Tic the box for Accept files from trusted devices > select a default destination folder > and then click Apply.

screenshot of the popup window for the Local Services options with the box ticked for Accept files from trusted devices. you also need to select a destination directory at this point or it will not allow you to click apply (not shown).

  1. Go back to the [other] system default bluetooth menu > hover your mouse cursor over your Phone/device > and toggle Connection before you send the file to Ubuntu.

screenshot showing the dropdown menu from the default system bluetooth menu with the mouse cursor hovered over the phone/device and the switch is toggled for "Connection"

Sharing from your phone should "just work".

NOTE: If the phone tries to send, but immediately fails, it may be a folder-permissions issue. Files sent via bluetooth are downloaded temporarily to ~/.cache/obexd, and if the owner/permissions of this folder aren't set correctly, the files can't be downloaded there and the transfer fails. Changing the folder's ownership and/or permissions so that your non-root account has read/write access to it should fix the problem.

[Original answer:]

For non-gnome/unity desktop-environments (Xmonad, XFCE, LXDE, etc.), the following works (tested on 15.04):

  1. Make sure you have the necessary dependencies installed:

    sudo apt-get install obex-data-server gnome-user-share
  2. Run gnome-file-share-properties from the command-line, and make sure Receive files in downloads folder over bluetooth and Notify about received file are enabled.

  3. Create a file ~/bin/start-bluetooth-listener which contains the following (the order is important):

    /usr/lib/gnome-user-share/gnome-user-share &

    (create the~/bin directory first if it doesn't already exist)

  4. Make the file executable:

    chmod +x ~/bin/start-bluetooth-listener
  5. Either manually run the ~/bin/start-bluetooth-listener script, or set up your desktop-environment to automatically run the script when you log-in (e.g. in XFCE, via the xfce4-session-settings tool).

Now if you try to send a file from your phone to your paired computer via bluetooth, it should work, and pop up a notification window after the file has been received.

  • in ubuntu-studio with xfce i get this error when run ./start-bluetooth-listener: ./start-bluetooth-listener: 3: ./start-bluetooth-listener: /usr/lib/gnome-user-share/gnome-user-share: not found
    – user385441
    Aug 8, 2016 at 21:17
  • Have you installed both packages before you did it? Mar 4, 2017 at 10:16
  • This almost worked for me but the magic glyph was running /usr/lib/gnome-user-share/gnome-user-share-obexpush. Maybe the file name has changed as there is not one without the -obexpush suffix.
    – Salix alba
    Apr 18, 2017 at 21:27
  • Blueman works. But it only lets me transfer pictures and not videos from my tablet.
    – SDsolar
    Aug 5, 2017 at 13:51

Bluetooth Settings on Ubuntu 20.04

On Ubuntu 20.04, remember that you have to keep the Bluetooth Settings open in order to receive files, otherwise Ubuntu will reject all transfers.

  • I'm running Lubuntu 20.04 I found that having ~/cache/obexd open in my file manager helped to insure that files were received. Jun 7, 2020 at 23:10
  • I found that having the Bluetooth Devices dialog box open also helped ensure successful transfers. Jul 1, 2020 at 4:23
  • In my case just opening settings didn't work, I had to connect to the sending device, then I'm able to receive files.
    – Dev Bhuyan
    Feb 28 at 19:17
  • Doesn't work for me at all. Have the phone connected, can send to it, but not receive from it.
    – misiu_mp
    May 5 at 20:28

go to bluetooth sittings and pair your device and choose the device that you want to send or connect audio speaker set shown and put sign on ( use your phone as, and send or play music

  • 1
    The question asked is regarding file transfer. You aren't addressing his problem with this solution. Nov 27, 2016 at 3:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .