103

I have a problem when I send my files from phone to ubuntu 12.04 via bluetooth as the phone prompts with the message "the file not sent"! I can send any files from ubuntu 12.04 to my android phone.

164

Go to Dash Home search for personal file sharing. If you don't have Unity installed, you can open the program from a terminal with typing gnome-file-share-properties in it.

Ubuntu Personal File Sharing Bluetooth

At the bottom of the box enable Receive files in downloads folder over bluetooth also enable Notify about received file then you're good to go :)

Personal File Sharing Application Ubuntu Bluetooth Sharing

  • 6
    How is the program name if I want to start that in a Terminal? – BuZZ-dEE Dec 18 '12 at 18:59
  • 7
    gnome-file-share-properties – Florian Echtler Jun 18 '13 at 8:09
  • 5
    this did not work for me on 64 bit Ubuntu 14.04 – faizal Jul 12 '14 at 15:21
  • 1
    Its worked for me on 32 bit Ubuntu 14.04. but didn't seen any notifications may be some error. – Mansoorkhan Cherupuzha Aug 25 '14 at 1:44
  • 1
    It only worked after rebooting both smartphone and computer (I'm on Ubuntu 14.04 64 bit) @faizal – chelder Mar 13 '15 at 15:08
7

[Updated answer tested on Ubuntu 16.04]

I have found that simply installing blueman and using the blueman applet works well:

  1. Install blueman:

    sudo apt-get install blueman
    
  2. Run the applet:

    /usr/bin/blueman-applet
    
  3. Pair your device using the applet

Sharing from your phone should "just work".

NOTE: If the phone tries to send, but immediately fails, it may be a folder-permissions issue. Files sent via bluetooth are downloaded temporarily to ~/.cache/obexd, and if the owner/permissions of this folder aren't set correctly, the files can't be downloaded there and the transfer fails. Changing the folder's ownership and/or permissions so that your non-root account has read/write access to it should fix the problem.


[Original answer:]

For non-gnome/unity desktop-environments (Xmonad, XFCE, LXDE, etc.), the following works (tested on 15.04):

  1. Make sure you have the necessary dependencies installed:

    sudo apt-get install obex-data-server gnome-user-share
    
  2. Run gnome-file-share-properties from the command-line, and make sure Receive files in downloads folder over bluetooth and Notify about received file are enabled.

  3. Create a file ~/bin/start-bluetooth-listener which contains the following (the order is important):

    #!/bin/sh
    /usr/bin/obex-data-server
    /usr/lib/gnome-user-share/gnome-user-share &
    

    (create the~/bin directory first if it doesn't already exist)

  4. Make the file executable:

    chmod +x ~/bin/start-bluetooth-listener
    
  5. Either manually run the ~/bin/start-bluetooth-listener script, or set up your desktop-environment to automatically run the script when you log-in (e.g. in XFCE, via the xfce4-session-settings tool).

Now if you try to send a file from your phone to your paired computer via bluetooth, it should work, and pop up a notification window after the file has been received.

  • in ubuntu-studio with xfce i get this error when run ./start-bluetooth-listener: ./start-bluetooth-listener: 3: ./start-bluetooth-listener: /usr/lib/gnome-user-share/gnome-user-share: not found – ateymuri Aug 8 '16 at 21:17
  • Have you installed both packages before you did it? – Dominic Hayes Mar 4 '17 at 10:16
  • This almost worked for me but the magic glyph was running /usr/lib/gnome-user-share/gnome-user-share-obexpush. Maybe the file name has changed as there is not one without the -obexpush suffix. – Salix alba Apr 18 '17 at 21:27
  • Blueman works. But it only lets me transfer pictures and not videos from my tablet. – SDsolar Aug 5 '17 at 13:51
-8

go to bluetooth sittings and pair your device and choose the device that you want to send or connect audio speaker set shown and put sign on ( use your phone as, and send or play music

  • The question asked is regarding file transfer. You aren't addressing his problem with this solution. – Logan Nov 27 '16 at 3:45

protected by Community Sep 30 '14 at 18:23

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.