1

Trying to install Lubuntu 20.04 on a Dell 1525 Laptop without its original Display that is broken. The display was disconnected and now the laptop is connected to an external display (LG E2244) with native resolution 1920x1080 px.

Lubuntu does install after booting into itself as a live disk, and there is not option to boot to the terminal and install from there. The system booted into Lubutu live disk, but at first sight there is a problem. The desktop does not fit to external monitor. This problem is easily observed by noticing the white border lines. See:

https://youtu.be/9W-QdJOL58E

img1

img2

img3

img4

As you can see there is not a white line on the left side of the desktop. Unfortunately, in order to start the installation, you have to click on the Install icon which is not visible. Why? Simply, the install and all other icons are on the left, but outside of the visible part of the screen. One option to revert this would be to access a terminal window by pressing CTRL+ALT+T , but this results in the terminal windows being opened in the left part of the desktop, outside the screen too. This is verified if you press CTRL+ALT+DEL, which fortunately opens in the visible part of the screen and you can see that the terminal process is running. No matter what you do, you can not move any window to the right side.

With no luck and already desperate, I had to try to access the file manager with some key combination and luckily I succeeded (Sorry, I don't know which key combination). With luck on my side, the file manager opened in the visible part of the screen and from there I could click on the installation icon.

The installation went very quickly and smoothly. We then proceeded to reboot after the installation was completed. The logon screen already in the desktop manager looks bigger than the LG display, but OK. Login has done and to my surprise, the initial problem came back. The desktop empty, only the cursor visible.

By investigating and reading different threads in the ubuntu community, I was able to figure out the cause of the problem and fix it myself.

The behavior of the mouse disappearing when moving it to the left edge caught my attention, moreover, the fact that the terminal process is running, although not visible, after pressing CTRL+ALT+T. A resolution issue in Lubuntu should be the cause of the problem. To obtain a visible terminal screen, we need to open a new session in tty2 by pressing CTRL+ALT+F2, it can be tty3, tt4, so it could be F3, F4, it does not matter.

After entering the login and password data, we can use the xrandr command to get information about the display and resolution, but we need to define on which display. To do this:

export DISPLAY=0:

and then

xrandr --listactivemonitors

Looking at the last two lines we could see that Lubuntu was detecting 2 active displays: LVDS-1 and VGA-1.

LVDS-1 is the original display which was broken and it was disconnected from the laptop. VGA-1 is the external display.

Conclusion: Lubuntu was using the VGA-1 display as an extension of LVDS-1.

To fix this, i.e. to disable LVDS-1 it is necessary to do this before OS boot into GUI.

This is done by editing the GRUB configuration. The commands are

sudo nano /etc/default/grub

then add "video=LVDS-1:d" to the line GRUB_CMDLINE_LINUX_DEFAULT.

It was GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

and now it is

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=LVDS-1:d"

save the configuration and exit nano.

Now, you have to update grub with the command:

sudo update-grub

to finish, just reboot with command

reboot

2
  • Gomez can you use the auto detect or auto resize buttons on your monitor? Probably easiest fix or hook it up to a TV. Once you get Lubuntu Installed, the graphics will most likely fix themselves. If not, let me know.
    – user175999
    Feb 11, 2021 at 17:59
  • I've installed various Lubuntu (and other flavors) onto a laptop with dead screen.. the easiest work around was using the Fn-display key of the laptop, which toggled between internal/external/internal+external/mirror/.. combinations... this worked on both ibm, lenovo, dell laptops (maybe more) it was tried on.
    – guiverc
    Feb 13, 2021 at 1:05

3 Answers 3

0

I have seen in your video that you have a nice desktop with a proper right-click context menu and all.

On this desktop, try a Ctrl + Alt + t to open a terminal.

Then try Ctrl + Alt + right arrow to move this window to the right half of the screen (that will put the part where you type around the middle.)

Alternatively, if you see any part of the terminal window already, then Alt + mousedrag will work on the entire surface of the window, so you already can drag it where you see it better.

Next, issue in the terminal xrandr --listmonitors This will reveal the identifier of that monitor, possibly something like HDMI-1.

Issuing just xrandr will list the available resolutions.

Then, in theory, you should be able to do something like this:

xrandr --output HDMI-1 --mode 1600x900

This will be a temporary fix that does not survive a reboot, but you may get a chance to fix it permanently within some settings UI.

0

Control+ALT+t did not open a terminal window, but trying to find the correct keys, I could open a file manager window (do not ask me which keys I pressed) so there is a Menu with Tool option, and Open terminal (see image). I clicked on this option, tried the F4 key but did not work or terminal window opened at the left side where I cannot see. Control +Alt +right arrow seems to not work. As I have access to the Install icon through this file manager I can click to install . However, now I can confirm there are some glitches with keyboard mapping (Keyboard hardware is Ok, because it was working on win7 this morning) . Every time I press D key I got the desktop screen, see video below img

video of keyboard prob. https://youtu.be/6EkEsTSNkck

1
  • Move all this info into the original question, maybe preceded by an "Update:".
    – Levente
    Feb 11, 2021 at 19:15
0

you are answering your own question. Its better to edit your original question. I'm sure a moderator will step in to fix both your and my responses, but that's just how a forum works. Anyways, Glad you could get Lubuntu installed! So, if you are experiencing problems with desktop size maybe a "windows key + p shortcut option" will fix your problem (extend, duplicate, only on monitor 1, only on monitor 2 etc). Try this other answer once you can get where you need to. Is there an equivalent to Win-P (Switch Video Output hotkey)?. Remember to get to the terminal to issue terminal commands you can usually use CTRL+ALT+F(X) where X is the number of your function keys at the top of the keyboard. It also sounds like your laptop keyboard is tricking you by either having numlock enabled or not enabled to make you type other than what you are typing. EDIT (looks like maybe [L]Ubuntu is trying to detect your keyboard as something other than US based on your region.) Make sure to setup your region and keyboard properly during Lubuntu install. (even if it detects your region correctly maybe it detects your hardware wrong) Hope this helps!

14
  • I am completely stuck. Lubuntu is installed but the desktop size does not allow me to do anything. I am almost giving up and wondering if other distro can run better on this old laptop. Feb 11, 2021 at 20:20
  • there are a few but they will further limit what you can get done with the laptop. can you get to a "dos screen" or full screen terminal from pressing CTRL + ALT + F1(any of the F keys)?
    – user175999
    Feb 11, 2021 at 21:02
  • you can also add a blank file in the root directory (~/) called "ssh" to enable ssh then ssh into the laptop from another to get what you need installed
    – user175999
    Feb 11, 2021 at 21:08
  • you really need another monitor that has the same graphics properties as your laptop minimally WXGA (1280X800) once you get all that under control you will be able to get the desktop size and display properties under control whether it be with the gui or terminal
    – user175999
    Feb 11, 2021 at 21:10
  • Yes, I can get a terminal with CTRL +ALT + F2. The monitor is a LG E2241 and it's native resolution is 1920x1080, so it is better than WXGA, so it should not be the problem. The problem is Lubuntu that configures itself with a strange desktop size Feb 11, 2021 at 21:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.