1

I have been upgrading my OS in stages to get to a current LTS version. Yesterday I ran 'do-release-upgrade' after running 'sudo apt-get update; sudo apt-get upgrade; sudo apt-get dist-upgrade' per recommendations in posts here. Post-upgrade, a number of broken dependencies appeared.

Now, synaptic, apt-get, and software-properties-gtk and many other important programs won't run, producing this error:

synaptic: symbol lookup error: /usr/lib/x86_64-linux-gnu/libpangoft2-1.0.so.0: undefined symbol: hb_font_funcs_set_variation_glyph_func

Commands like apt --fix-broken install or sudo apt-get install -f, and the other usual recommendations have not corrected the issue. Are there different strategies to try?


$ which synaptic
/usr/sbin/synaptic

$ dpkg -S $(which synaptic)
synaptic: /usr/bin/synaptic

$ ldd $(which synaptic) | grep local
# produces no result. 

$ dpkg -S /usr/lib/x86_64-linux-gnu/libpangoft2-1.0.so.0
libpangoft2-1.0-0:amd64: /usr/lib/x86_64-linux-gnu/libpangoft2-1.0.so.0
$ apt-cache policy synaptic libpangoft2-1.0-0
synaptic:
  Installed: 0.83
  Candidate: 0.84.3ubuntu1
  Version table:
     0.84.3ubuntu1 500
        500 http://us.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
 *** 0.83 100
        100 /var/lib/dpkg/status
libpangoft2-1.0-0:
  Installed: 1.40.14-1ubuntu0.1
  Candidate: 1.40.14-1ubuntu0.1
  Version table:
 *** 1.40.14-1ubuntu0.1 500
        500 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
        100 /var/lib/dpkg/status
     1.40.14-1 500
        500 http://us.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
spowell@raven:/etc/apt$ apt-cache policy synaptic libpangoft2-1.0-0
synaptic:
  Installed: 0.83
  Candidate: 0.84.3ubuntu1
  Version table:
     0.84.3ubuntu1 500
        500 http://us.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
 *** 0.83 100
        100 /var/lib/dpkg/status
libpangoft2-1.0-0:
  Installed: 1.40.14-1ubuntu0.1
  Candidate: 1.40.14-1ubuntu0.1
  Version table:
 *** 1.40.14-1ubuntu0.1 500
        500 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
        100 /var/lib/dpkg/status
     1.40.14-1 500
        500 http://us.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

The output of 'dpkg -l | grep ^ii -v' is available at pastebin https://pastebin.com/HhJu3mZu

The output of 'sudo aptitude safe-upgrade' is:

> The following packages will be REMOVED:  
  groff-base{u} libgdbm5{u} libpipeline1{u} man-db{u} 
The following partially installed packages will be configured:
  bsdmainutils libbsd0 liblocale-gettext-perl libsmartcols1 libtinfo5 libuuid1 
0 packages upgraded, 0 newly installed, 4 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 6,017 kB will be freed.
Do you want to continue? [Y/n/?] Y
dpkg: error: duplicate file trigger interest for filename '/usr/lib/gdk-pixbuf-2.0/2.10.0/loaders' and package 'libgdk-pixbuf2.0-0:i386'
E: Sub-process /usr/bin/dpkg returned an error code (2)
dpkg: error: duplicate file trigger interest for filename '/usr/lib/gdk-pixbuf-2.0/2.10.0/loaders' and package 'libgdk-pixbuf2.0-0:i386'


13
  • Please show the output of the following commands to the question: which synaptic, dpkg -S $(which synaptic), ldd $(which synaptic) | grep local, dpkg -S /usr/lib/x86_64-linux-gnu/libpangoft2-1.0.so.0 , apt-cache policy synaptic libpangoft2-1.0-0 .
    – N0rbert
    Feb 11, 2021 at 14:35
  • Have you tried to use Aptitude? Something like sudo apt install aptitude, sudo aptitude dist-upgrade to get newest dependencies.
    – N0rbert
    Feb 11, 2021 at 14:50
  • 'which synaptic':
    – Da Kong
    Feb 11, 2021 at 16:09
  • Add all outputs to the question by editing it.
    – N0rbert
    Feb 11, 2021 at 16:14
  • 'which synaptic': yields /usr/sbin/synaptic. 'dpkg -S $(which synaptic)' yields synaptic: /usr/bin/synaptic. 'ldd $(which synaptic) | grep local' produces no result. 'dpkg -S /usr/lib/x86_64-linux-gnu/libpangoft2-1.0.so.0' produces 'libpangoft2-1.0-0:amd64: /usr/lib/x86_64-linux-gnu/libpangoft2-1.0.so.0'. 'apt-cache policy synaptic libpangoft2-1.0-0' produces 'synaptic: Installed: 0.83 Candidate: 0.84.3ubuntu1 Version table: 0.84.3ubuntu1 500 500 us.archive.ubuntu.com/ubuntu bionic/universe amd64 libpangoft2-1.0-0: Installed: 1.40.14-1ubuntu0.1
    – Da Kong
    Feb 11, 2021 at 16:17

1 Answer 1

0

The solution of the problem was multi-step:

  1. Install all upgrades without package removal by

    sudo aptitude safe-upgrade
    
  2. Remove duplicate trigger /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders from /var/lib/dpkg/triggers/File

To get all upgrades installed I would recommend to run

sudo apt-get update
sudo apt-get dist-upgrade

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.