0

VirtualBox 6.1.18
Host: Windows 10
Guest: Xubuntu 20.04
Guest extensions installed and active

None of the CTRL+Fn key combinations seem to work in any program I tried (Visual Studio Code, LibreOffice, etc.)

Interestingly, CTRL+SHIFT+Fn combinations seem to work fine.

Please advise.

Edit:

I tried the Keyboard Event Viewer inside the VM. When the CTRL key was pressed, none of the F1-F12 key presses registered. They did register when the CTRL key was not pressed, or when it was pressed in combination with the SHIFT key.

Similarly, I see the same when I run xev | grep -E -A3 "^KeyPress" (as suggested in a comment to another question)

This happens with the built-in Thinkpad keyboard, with the wireless Logitech K800, and with the VirtualBox on-screen "soft keyboard". Remapping the HOST key combination did not help.

I am at a loss.

1
  • Found the answer here. It was an XFCE issue.
    – Alex O
    Feb 25 '21 at 15:38
0

The issue turned out to be with XFCE rather than virtualBox.
By default, it maps CTRL+Fn combinations to switch to the corresponding workplaces.

See the answer to another question here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.