2

I am using Apple Airpods and recently installed a new 20.04 version on my laptop. The Airpods connect but the sound at the beginning of usage is a bit choppy. After a few seconds it works smoothly. Then, at some random point in time the sound gets choppy and either recovers or ends up to stop working completely. I then have to restart bluetooth and reconnect the headphones. Rinse and repeat. I tried the solutions here: Bluetooth randomly cutting out in Ubuntu but they did not work.

I am using kernel 5.8.0-41-generic and I am connected to the internet via an Ethernet cable.

Any help is greatly appreciated.

Edit:

BT Device:

03:00.0 Network controller [0280]: Intel Corporation Wireless 8265 / 8275 [8086:24fd] (rev 78)
    Subsystem: Intel Corporation Dual Band Wireless-AC 8265 [8086:0010]
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 0bda:0316 Realtek Semiconductor Corp. USB3.0-CRW
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 04f2:b604 Chicony Electronics Co., Ltd Integrated Camera (1280x720@30)
Bus 001 Device 003: ID 0461:4d51 Primax Electronics, Ltd 0Y357C PMX-MMOCZUL (B) [Dell Laser Mouse]
Bus 001 Device 002: ID 046a:0113 Cherry GmbH CHERRY Wired Keyboard
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
3
  • I cannot comment yet so writing here. Sounds like a driver issue but please provide more information. Either run sudo btmon, or share the related part of /var/log/syslog. My biggest guess would be it is due to corrupted PulseAudio., however it might be also related to the bluez as well. Hence, please try the solution available here. – Mr. Panda Feb 8 at 13:53
  • What is the BT device? Please edit your question and add output of lspci -knn | grep Net -A3; lsusb terminal command. – Pilot6 Feb 8 at 14:40
  • Hi @Pilot6 just edited my post. – mikanim Feb 8 at 15:45
2

If you are using 2.4 GHz Wi-Fi at the same time, this could be a reason why this is happening. Try to disable bt_coex by running:

sudo tee /etc/modprobe.d/iwlwifi-opt.conf <<< "options iwlwifi bt_coex_active=N"

Reboot to test.

The setting can be reverted by:

sudo rm /etc/modprobe.d/iwlwifi-opt.conf
7
  • Tested for almost a full day of work and it seems to have solved the problem. Many thanks for the help. It is weird though because my wifi is usually off as I use an ethernet cable. Could simply having bt_coex running have caused the problem and not necessarily connecting to wifi? – mikanim Feb 9 at 11:45
  • It may be. The bt_coex technology is really poor in iwlwifi. But it is enabled by default. – Pilot6 Feb 9 at 11:46
  • Is there another driver that ubuntu users should/could use? – mikanim Feb 9 at 11:47
  • No, there is no separate BT driver. – Pilot6 Feb 9 at 11:48
  • Ok thanks and lastly would keeping it disabled have any side effects? I.e. wifi not working stably or so. – mikanim Feb 9 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.