I have 12.04 running on Intel dual core with Nvidia 8400 GS. I had installed the post-relase updates for Nvidia, but encountered some problems, so removed [deactivated] them through "Aditional drivers".

After restarting, when I went to install the recommended version current drivers through "Additional drivers", I get the following error:

Sorry, installation of this driver failed.

Please have a look at the log file for details: /var/log/jockey.log

Remove all possibly installed packages:

sudo apt-get remove nvidia-173 nvidia-current nvidia-current-updates

Clean up:

sudo apt-get autoclean
sudo apt-get autoremove

Install driver:

sudo apt-get install nvidia-current-updates
|improve this answer|||||

You can try this link and follow the instructions:

It works fine in my computer when I successfully installed it.

Steps :

  1. Go to http://www.nvnews.net/vbulletin/showthread.php?s=8ef6fcfc7083462c3969f5bd80cee8e1&t=122606

  2. Select and click Desire Nvidia Version [173,96,etc], then click the FTP link

  3. Download the .run file (ex. NVIDIA-Linux-[]-pkg[].run)

  4. Run the file in the terminal -> sh NVIDIA-Linux-[]-pkg[].run

Another solution that I found out is this :

In my case, Im using Linux Mint, but i guess that all repositories in this os is still the same as in Ubuntu, Using Linux Mint Maya (Ubuntu 12.04 equivalent in precise) I followed this forum


Since Nvidia-96 is not available on any higher versions (precise and upper i guess), in this forum, they tried to get the Nvidia package to a lower ubuntu version (oneiric) and use it to their current OS and downgrade their xorg to oneiric.

Now these steps are still working in my system, and I'm using oneiric nvidia-96.

|improve this answer|||||

you can't do it with solution use for ubuntu 11.10 because in 12.04 had a driver nvidia default open sources.

  1. you stop x sever and active nvidia common -> pc warning can't install driver nvidia reboot pc after you see interface 2D unity
  2. continue stop x sever now you can install driver nvidia as solution with ubuntu 11.10
|improve this answer|||||
  • 1
    I don't know what you're doing and how you think installation of proprietary drivers works, but I had no problem installing the proprietary drivers while nouveau was active, neither for 12.04 nor 11.10 nor the versions before. Please try to use formatting. – LiveWireBT May 7 '12 at 8:15

I tried all solutions, and none worked for me...

Then, without X, I just removed all nvidia stuff, rebooted the computer... for my surprise, it was all working by itself... instead of using nvidia-current/current-updates drivers, Unitiy solved it for me (and I can even handle the monitors in the "Display" application, as never did before).

Kudos for Ubuntu!

|improve this answer|||||

To install/Update Nvidia card drivers open Terminal and copy the following commands in the terminal:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

When installation complete restart your PC. Now to check the installation is successful Press Window/Super key and type: nvidia x server settings and open it.

That's it Enjoy.

|improve this answer|||||
  • 1
    Version: 295.33-0ubuntu1~precise~xup1. Those packages are currently older than the ones from the Ubuntu repository (295.40) which fix a severe security issue. You should know the contents of PPAs before giving others advice to install them. – LiveWireBT May 7 '12 at 7:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.