1

Hi guys i need some help to fix this problem in packet tracer in my Ubuntu 20.04

gp@gp-GL552VX:~/Downloads$ sudo apt install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  libfprint-2-tod1
Use 'sudo apt autoremove' to remove it.
The following packages will be REMOVED:
  packettracer
0 upgraded, 0 newly installed, 1 to remove and 1 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 249903 files and directories currently installed.)
Removing packettracer (7.3.1) ...
gtk-update-icon-cache: Cache file created successfully.
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for gnome-icon-theme (3.12.0-3) ...
Processing triggers for shared-mime-info (1.15-1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...

gp@gp-GL552VX:~/Downloads$ sudo dpkg -i PacketTracer_731_amd64.deb
Selecting previously unselected package packettracer.
(Reading database ... 246567 files and directories currently installed.)
Preparing to unpack PacketTracer_731_amd64.deb ...
Unpacking packettracer (7.3.1) ...
dpkg: dependency problems prevent configuration of packettracer:
 packettracer depends on dialog; however:
  Package dialog is not installed.
 packettracer depends on libgl1-mesa-glx; however:
  Package libgl1-mesa-glx is not installed.

dpkg: error processing package packettracer (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for gnome-icon-theme (3.12.0-3) ...
Processing triggers for shared-mime-info (1.15-1) ...
Errors were encountered while processing:
 packettracer
gp@gp-GL552VX:~/Downloads$ 

image

1
  • 2
    The error clearly states you're missing a dependency. Try this: sudo apt install libgl1-mesa-glx, then try to install the packet tracer again.
    – user1091774
    Feb 7, 2021 at 13:37

1 Answer 1

4

Install the missing dependencies (dialog and libgl1-mesa-glx):

sudo apt install libgl1-mesa-glx dialog

Or use gdebi:

sudo apt install gdebi
sudo gdebi PacketTracer_731_amd64.deb
2
  • thank you very much! Feb 8, 2021 at 21:56
  • Hi I'm having a problem again regarding installing: sudo apt install libgl1-mesa-glx dialog Feb 11, 2021 at 11:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .