This just seems like a common problem, however I was not able to find a solution on the net. For some reason Ubuntu doesn't like WPA/WPA2 personal encryption. I can connect to the network fine (others have reported they are not able to connect and the 'Authentication Required Window' keeps on appearing), however I am unable to connect to the internet.

When I change the security settings of the router to 'Open' or to 'WEP' I can connect fine. However 'WEP' slows down the connection by a factor of 2. Several people have suggested to use 'wicd' instead of 'network-manager' I tried that but I got the same problems.

Please note that I have had this problem with Ubuntu 11.10 and now it seems it has carried over to 12.04.

Also note that I dont think it is a problem with the wireless router (Medialink) because my Windows 7 machine, iPad and Android phone all connect fine. Any ideas? Thanks in advance

  • It seems that Ubuntu has some incompability issues with WPA/TKIP. Can you change to WPA2/AES? Does it work for you? – user57108 May 5 '12 at 12:05
  • It was an issue with the realtek driver. Thanks for all the answers – Jeanno May 12 '12 at 19:41
  • Do you have a solution for people with realtek drivers? This question has gotten 10k views and there's probably people who could figure out how you solved this! – Jorge Castro Nov 21 '12 at 21:08
  • I have faced the same issue , you can resolve this problem if you can change router WPS settings to use just WPA-Personal and TKIP as encryption I had same problem superuser.com/questions/642867/… the problem is being caused by the way Ubuntu handles encryption, in Windows I changed the settings to TKIP it is easily able to get to internet where as in Ubuntu 12.04 I see only WPA& WPA2 Personal Ubuntu probably is not able to detect type of encryption at router – Registered User Sep 12 '13 at 6:43

I don't think this is an Ubuntu problem per se -- it is likely caused by the interaction between your wireless chipset, software driver, and the software and hardware of the wireless access point or router. I've seen this with various devices from completely different vendors, running different OS's, and issues with connecting with wireless routers/AP's from different enterprise vendors (Cisco, Meru, Aruba, etc.). In other words, it is likely not restricted to Ubuntu.

The driver situation in Linux is getting better and better, but you may want to track down specifics for your chipset and make sure you have the most recent drivers. Also, do some searches to see if there are known issues with the brand/model of your wireless router or AP and your hardware.
Often, the most recent driver can be found on the laptop or adapter vendor's website.

What is your computer model, wireless device model, and router model (i.e., what model of "Medialink")? lspci and/or lshw should help you find your wireless model and perhaps chipset.

Here's some generic info: If you haven't already, run jockey-gtk to check your driver update status. You can also use the Super key (sometimes known as the Windows key) to open the dash, then type in "driver". "Additional drivers" should appear as an application. If nothing appears there, please check out the "Help" option there.

It will open an info page on proprietary drivers. At the bottom of that page, there's a link for more information, with a link to "Hardware & Drivers". Click through to that, scroll to "Common Problems", and finally, check the link which is titled, "Wireless network troubleshooter". If you're lucky, you'll find something helpful there as well.

Also see Supported Wireless cards and Ubuntu Wireless Networking Documentation.

| improve this answer | |

run iwconfig to check the ESSID is correct, then run ifconfig to check if you have a valid IP, then you could try some ping tests to the router then to google. nm-tool might provide some details also.

Checking /var/log/syslog for errors would be a good idea also

| improve this answer | |

I managed to overcome this by trying to connect with security disabled and then re-activating WPA2 and re-entering the (same) key. This may, of course, have been coincidence and I inadvertently altered something else! (Ubuntu 12.04, Belkin N1 router and Samsung Netbook N10)

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.