13

I'm using Ubuntu 20.04 on an essentially-brand-new Lenovo IdeaPad 3 (with an external USB mouse), and use Google Chrome as my primary web browser. Lately, I've been having a really irritating problem: sometimes, seemingly at random, Chrome loses the ability to sense when I right-click on a browser tab or on the forward/back buttons, and attempting to right-click on a tab or one of the aforementioned buttons simply triggers the left-click action for what was clicked on, rather than bringing up the requisite right-click menu. Hovering the cursor over a tab also no longer brings up the name of the webpage in that tab, no matter how long the cursor stays over the tab. Sometimes, Chrome spontaneously starts responding to right-clicks and tab hovering again, but sometimes the right-click-nonresponsiveness lasts for the whole rest of the browsing session.

What the hell is going on and how do I fix it?

EDIT: The problem resolved itself after I inadvertently brought up the on-screen keyboard (I spotted a speck of dust on the touchscreen, and, in brushing it off, activated the on-screen keyboard); after dismissing the keyboard, tab right-clicking and hovering worked properly again. Still confused as hell, though.

5
  • 3
    I'm seeing the same issue. Other apps work fine; it's just Chrome that has this issue. The right-click does work in website content area, but no on tab bar, the bookmarks bar or the nav buttons. Bizarre. Commented Jun 7, 2021 at 23:36
  • 2
    @AshleyWilson: Did bringing up the on-screen keyboard and then dismissing it resolve the issue for you, like it did for me?
    – Vikki
    Commented Jun 7, 2021 at 23:54
  • 1
    Tried that, didn't work, but rebooting seems to have worked, at least for now. Commented Jun 8, 2021 at 1:50
  • 2
    Bringing up the on-screen keyboard also worked for me. Hopefully we get an explanation one day Commented Sep 2, 2021 at 8:16
  • 1
    Fixed it for me. What a weird bug! Right clicked worked everywhere else fine.
    – SimonAlfie
    Commented May 5, 2023 at 9:21

3 Answers 3

9

I was able to stop this behaviour by tapping once anywhere on the touch screen.

Dorian's answer reminded me of an issue with IntelliJ, where the mitigation was the same.

2

I had the same issue on Ubuntu 20.04, right clicking / middle clicking on Chrome tabs respectively didn't bring the menu / close the tab.

This was due to the touch screen of my laptop (I imagine Chrome thought I was on a tablet).

I also spotted issues with Nautilus: drag'n'drop triggered too often.

To fix it, I disabled the touch screen:

xinput --disable $(xinput --list | grep -i 'finger touch' | grep -o 'id=[0-9]*' | sed 's/id=//')

Notes:

  • "finger touch" needs to be replaced with a part of your touch screen's name, it can be retrieved with xinput list, e.g. on my side:
    ⎡ Virtual core pointer                        id=2    [master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer                  id=4    [slave  pointer (2)]
    ⎜   ↳ DP-1                                        id=8    [slave  pointer (2)]
    ⎜   ↳ Wacom HID 4943 Finger touch                 id=11   [slave  pointer (2)]
    ⎜   ↳ DLL0945:00 06CB:CDE6 Touchpad               id=13   [slave  pointer (2)]
    ⎜   ↳ MX Keys Consumer Control                    id=21   [slave  pointer (2)]
    
  • This command must be rerun after a reboot (to avoid that, I add it to my ~/.bashrc).
1
  • 1
    thanks for this! I didn't need to disable mine. But the touch screen was a good thought.
    – Dave Ankin
    Commented Jan 25, 2022 at 13:20
0

I had the same issue on my Ubuntu 18.04.6. I had disabled the touchscreen on my laptop. I just enabled it and disabled it again, and now everything works fine. Steps I followed are as follows:

  • Find the the touchscreen input using xinput list
  • Find ID of touchscreen device. In my case the name was ELAN Touchscreen
  • xinput disable <device_id>
  • xinput enable <device_id>

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .