1

My laptop HP ZBook Fury 15 G7 Mobile Workstation has the problem that there's no sound after I suspend and resume it. The only solution I found so far is reboot. I have 2 cards on my laptop, one is HDA Nvidia controlled by snd_hda_intel driver and the other is sof-hda-dsp controlled by snd_soc_skl_hda_dsp driver. Not sure about Nvidia card - didn't use it so far, but the problem is with the latter, which is my "main" sound card labeled Realtek ALC285. Sound works fine until I suspend and resume the laptop and nothing in the log seem to point to the cause of the problem...

logs from alsa-info when sound is working: https://pastebin.com/0CuJWiG1

When it's not working (after resume): https://pastebin.com/CGD2GDGb

the logs are from when I added the following to /etc/modprobe.d/alsa-base.conf:

options snd slots=snd_soc_skl_hda_dsp
options snd_soc_skl_hda_dsp index=0
options snd-hda-intel index=1

Think I tried most solutions I could find on the net. Re-inserting snd_soc_skl_hda_dsp hangs forever. I also had this problem with pulseaudio being started by gdm, I stopped it but it didn't make any difference so not sure how important it is.

Another strange thing is that although the sound card is reported as 2 channel, it seems like the front-left channel is the only one that works, but all speakers are playing as if it was one giant mono speaker only. Playing anything on front-right or changing balance results in no sound.

Would be grateful for any help, it's really hard to work if I have to restart the laptop each time I suspend it. Thanks!

0

I solved the issue by updating to 5.11-rc7 kernel. This required a manual patch of nvidia-460 driver which was incompatible with this kernel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.