12

Helo, why there is no ALT+F10 (maximize) or ALT+F9(minimize) shotcut in ubuntu 12.04? Or can i enable them somewhere?

  • On the behalf of those who have to make a living using an IDE which grabs a lot of keys: Dear Canonical - please, only steal key combinations involving "Super" (the Windows key). You are making the life of power users miserable. If you MUST, then make it possible to undo these in the standard Settings dialogue. – Thorbjørn Ravn Andersen Oct 5 '17 at 13:14
9

If you are on unity, then click the cog in the upper- right corner and choose System Settings

Now find the Keyboard entry, there you will be able to edit all your shortcuts.

You are looking for Maximize window and Minimize window they can be found under Windows. Just set the shortcut to whatever you want it to be.

enter image description here

  • 1
    In 13.04, Maximize window has been changed to Ctrl+Super+Up. – Jackson Sep 8 '13 at 19:46
7

There is already a bugreport: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/955965

this solution worked for me (comment #3)

Unity design has decided to use Alt+F10 to show menus starting in Ubuntu 12.04. This >means you can no longer use Alt+F10 to maximize a window.

WORKAROUND 1: 1. Run "ccsm" and go to General Options > Key Bindings. 2. Scroll down to "Maximize Window" (or "Toggle Window Maximized") and change the >keyboard shortcut.

WORKAROUND 2 (should work, but doesn't seem to!?): 1. Run "ccsm" and go to Ubuntu Unity Plugin >Behaviour. 2. Disable "Key to open first panel menu" (Alt+F10).

  • 1
    Workaround 2 "Run "ccsm" and go to Ubuntu Unity Plugin >Behaviour. 2. Disable "Key to open first panel menu" (Alt+F10)." works for me in 14.04 – Scott Newson Apr 8 '15 at 15:32
4

The default minimize key seems to be ctrl+alt+numpad 0

(see: Why don't Unity's window placement shortcuts work?)

for maximize ctrl+super+

2

You can maximize windows by Super+̣↑ and minimize by Ctrl+Super+̣↓.

For more keyboard shortcuts hold down Super or take a look at System SettingsKeyboardShortcutsWindows.

There you also can re-enable the old behaviour, but you have do disable the F10 keybinding first, which is described here.

  • i don't know, how to do the .↑ but changing the settings in the System settings > Keyboard > Shortcuts > Windows works for me, thanks – LetynSOFT May 5 '12 at 10:49
  • It is just the up-arrow. – Jakob May 5 '12 at 11:02
2

Just hold 2-3 sec. Super-Key and you will get a pop-up window with supported shortcuts

-1

Real working solution is in here https://bbs.archlinux.org/viewtopic.php?id=129872 and then htop or mc works as before!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.