1

I am trying to install utorrent in my pc,which has 20.04 ubuntu install,following this https://tipsonubuntu.com/2020/05/26/install-%C2%B5torrent-ubuntu-20-04/ guideline. but can not start the server . "utserver: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory" this error show when i ran "utserver -settingspath /opt/utorrent-server-*/ &" command.What should I do? Any help will be deeply appreciated.

1
  • Did you download and install the libssl.so.1.0.0 from the 18.04 repository like the instructions show and link to? – Terrance Feb 4 at 3:19
0

It seems that you forget to manually download required LibSSL library package. Download and install it with:

cd ~/Downloads
wget http://archive.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0.0_1.0.2n-1ubuntu5.5_amd64.deb
sudo apt-get install ./libssl1.0.0_1.0.2n-1ubuntu5.5_amd64.deb

and then retry.

2
  • That worked.Thanks a lot ! – user592993 Feb 4 at 11:50
  • Great, so you can accept this answer to mark problem solved. – N0rbert Feb 4 at 11:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.