7

Trying to resolve:

nslookup testserverinlocaldns

Server: 127.0.0.1

Address: 127.0.0.1#53

** server can't find testserverinlocaldns: NXDOMAIN

After 10 seconds everything is ok:

nslookup testserverinlocaldns

Server: 127.0.0.1

Address: 127.0.0.1#53

Name: testserverinlocaldns.localnet

Address: 192.168.3.8

And the same thing again and again. Sometimes it resolves, sometimes not. When I set resolv.conf to local DNS servers manually - everything is ok. But after reboot it gets back to 127.0.0.1 again.

8

I have this inside my internal network, and I solved it by disabling the local forwarding nameserver controlled by NetworkManager (dnsmasq).

To do that, you need to edit /etc/NetworkManager/NetworkManager.conf and comment out the “dns=dnsmasq” line in the "[main]" section.

Open a terminal, and run

sudo nano /etc/NetworkManager/NetworkManager.conf

Then make sure that the line

dns=dnsmasq

is commented out like this:

#dns=dnsmasq

Now, restart network-manager with the following command, and everything should work properly.

sudo restart network-manager

2
  • it works thatnks!
    – kay
    May 4 '12 at 13:27
  • 2
    Yes, it worked for me as well! kay, since it worked for you I'd suggest doing him the courtesy of accepting this answer.
    – memilanuk
    Jun 1 '12 at 4:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.