5

I have the dock auto-hide feature enabled, which works as expected except when I'm on the Desktop. There, it won't hide. It's pretty annoying considering I have files I want to see and interact with, which are being partially hidden by the dock...

Any idea what's going on?

Thanks in advance. enter image description here

enter image description here

4
  • 1
    As the message under "Auto-Hide the Dock" states: The Dock hides when any windows overlap with it. If there is nothing using the same screen area, the dock will be visible 🤔
    – user1091774
    Feb 3, 2021 at 22:57
  • 2
    @Matigo Although you're right, I somehow expected it to behave the same way it did on Ubuntu 16. I really don't understand the purpose of changing this. Thanks for noticing, anyway!
    – 89f3a1c
    Feb 4, 2021 at 1:05
  • 1
    @89f3a1c "I really don't understand the purpose of changing this." 16.04 by default had shipped with the Unity desktop, Canonical's in-house-developed desktop environment. Sometime after 16.04 however Canonical announced abandoning the Unity effort, and started shipping newer versions equipped with the independently developed Gnome desktop, which is a pretty different beast. So some of the changes you encounter might not have been implemented on purpose; rather, they just so "happened" through the switching of desktop providers, I believe...
    – Levente
    Feb 4, 2021 at 1:23
  • @Levente I was aware of the change from Unity to Gnome, though again I've not had it present, so thanks for bringing it up! It seemed strange to me to let items on the desktop be hidden by the dock anyway, so I initially thought I was missing something, and not that they missed it. But hey, problem solved, luckily!
    – 89f3a1c
    Feb 4, 2021 at 2:26

3 Answers 3

10

You can get finer-grain control over how the dock behaves via the gsettings API.

If you wish to deal with these settings via a graphical user interface, then you can install the dconf-editor app:

sudo apt install dconf-editor

Open it and navigate to the org.gnome.shell.extensions.dash-to-dock schema, or, for a similar effect use the search button and search for "dash-to-dock".

You will be presented with a number of settings (presented in alphabetical order).

The most interesting ones for your case are quoted below.

I believe that I have the dock set up to behave in a similar way that you are aiming for — it shows up only when I move my mouse cursor to the left edge of the screen — so I also share my settings:


autohide
Dock shown on mouse over

I have this enabled ^^


dock-fixed
Dock always visible

I have this disabled ^^


intellihide
Dock dodges windows

I have this disabled ^^ (I think this is the most significant one impacting the behavior in question.) (By default, it was enabled.)


pressure-threshold

I have this ^^ set to 50


require-pressure-to-show
Require pressure to show the dash

I have this enabled ^^

2
4

The answer by @Levente is correct. If you'd like to use the command-line to adjust the appropriate setting, without having to install dconf-editor, simply run the following:

gsettings set org.gnome.shell.extensions.dash-to-dock intellihide false

1
  • Oh, cool! Thanks for sharing!
    – 89f3a1c
    Dec 14, 2021 at 0:06
-1

You can disable the Dodge windows setting

dialog with toggle and options

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.