4

Trying to install Ubuntu Server 20.04.1 from ISO virtually mounted at ILO4. I get this integrity check, which takes ages How to skip? Integrity Check Issue

It's insane. Takes more than half an hour now and nothing...

4
  • No. This is when booting from virtual media (imitating CD) on a server when trying to install the OS.
    – svet0slav
    Feb 3, 2021 at 11:54
  • 1
    Additional info belongs as an edit to the question not as a comment.
    – David
    Feb 3, 2021 at 13:31
  • Are you installing onto bare metal? Or into a VM or container? Your output indicates that your system disabled caching, so yes the check is going to take a long time.
    – user535733
    Feb 3, 2021 at 13:48
  • I went out shopping and it finished. Now I am installing. Yes - on bare metal. Would be good to know how to skip this. Also there appears to be 20.04.2 installer, which is being downloaded now. Strange. It is not available on the ubuntu site, yet.
    – svet0slav
    Feb 3, 2021 at 13:52

2 Answers 2

11

I was plagued with this issue as well, would easily take 40+ minutes for the check to finish when using IPMI virtual media.

I believe I've found a workaround for now.

  1. Spam press Ctrl+C as soon as you see the purple screen appear after booting from ISO. You should see the following screen after pressing Ctrl+C:

    enter image description here

  2. Select your language, press Enter. Then, once the screen is at Install Ubuntu Server, select F6 Other Options:

    enter image description here

  3. Press Esc to close the dialog box in the bottom left corner. At this point, you should be able to type on the line that starts with Boot Options.... Replace quiet with fsck.mode=skip, then press Enter:

    enter image description here

At this point you should be able to boot without disk verification which is very fast over an IPMI-mounted disk.

1
  • At the grub prompt for install ubuntu server you need to hit 'e' then add "fsck.mode=skip" immediately before "quiet" (add a space before and after "fsck.mode=skip") then hit F10 or ctrl+x, I tried adding it to the very bottom and it didn't work, more info here : bugs.launchpad.net/ubuntu/+source/casper/+bug/1892369/comments/…
    – sabujp
    Mar 5, 2022 at 18:35
0

Worked for me without having to do it before the Grub menu. I just hit F6 a couple more times after inputting the line of text at the bottom and it takes right off. One thing to note if you are using SuperMicro IPMI, is to change your Hot Key for F6 (other wise it will reboot).

Great fix!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.