0

I bought a Lenovo Ideapad 1 11ADA05 recently. It was an emergency and I thought the price was quite good for this configuration, just like thousands of others (apparently it's selling pretty well).

During the installation, Ubuntu does not recognize the internal disk (eMMC). In don't think this is an Ubuntu issue, I've tried quite a few distros (Ubuntu 20.04 / 20.10, Pop OS, Mint) to no avail. I've tried pretty much all the combinations of bios options (UEFI, legacy support, secure boot,..)

I can't believe there are so many unresolved cases escalated online, yet no viable solution. I've been using Linux at home for more than 20 years now. I'm far from a power user or an expert but it never took me more than a few hours to fix any problem with the help of the community (and I'm talking about dozens of problems), even 20 years ago when there were significantly fewer users you could get help from.

I'll keep trying of course and keep you posted if I can fix it.

Are we really stuck with windows in the year 2021? It feels weird.


Thanks Jad for replying. I've been trying Manjaro now. lshw doesn't work in Manjaro but here's the lsblk output.

[manjaro@manjaro ~]$ lsblk -f NAME FSTYPE FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT loop0      squash 4.0                                                    0   100% /run/miso/ loop1      squash 4.0                                                    0   100% /run/miso/ loop2      squash 4.0                                                    0   100% /run/miso/ loop3      squash 4.0                                                    0   100% /run/miso/ sda  iso966 Jolie MANJARO_XFCE_2021 │                       2021-01-03-08-16-14-00                     0   100% /run/miso/ ├─sda1 │    iso966 Jolie MANJARO_XFCE_2021 │                       2021-01-03-08-16-14-00                               └─sda2      vfat   FAT12 MISO_EFI                         C274-6DF3


Thanks Matigo for the comment. I've seen that report. There are a few posts in different forums where people claim they fixed this problem (working around UEFI, installing additional eMMC drivers before the main installation, etc.) but I'm not convinced. Based on my 20 years of experince on Linux issues and forum support, I'd say if there was any realistic solution (no matter how complex it is), it would spread quite quickly. But there are still hundreds of unresolved cases. After countless attempts with different distros and bios configurations, I think I'm about to accept the cold truth that there's no solution for this for the time being. I hope it draws enough attention that somebody addresses it soon.

2
  • can you include the output from something like lshw ?
    – Jad
    Feb 3, 2021 at 11:44
  • 1
    Based on this probe report from Linux Hardware, you will have one heck of an uphill battle with that machine. It doesn’t look impossible, as the report was made from Ubuntu 20.10, but there’s an awful lot of detected devices and very few marked as working 🤔
    – user1091774
    Feb 3, 2021 at 11:59

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.