1

Im a fairy new user at Linux.

I have Ubuntu 18.04 on a host at paperspace.

I'm following this guide: https://www.teknotut.com/en/install-vnc-server-with-gnome-display-on-ubuntu-18-04/

Beside that I installed ZeroTier for VPN access.

Everything in the guide worked fine except this line:

sudo systemctl enable gdm

I get the following error:

The unit files have no installation config (WantedBy, RequiredBy, Also, Alias

settings in the [Install] section, and DefaultInstance for template units).

This means they are not meant to be enabled using systemctl.

Possible reasons for having this kind of units are:

A unit may be statically enabled by being symlinked from another unit's

.wants/ or .requires/ directory.

  1. A unit's purpose may be to act as a helper for some other unit which has

a requirement dependency on it.

  1. A unit may be started when needed via activation (socket, path, timer,

D-Bus, udev, scripted systemctl call, ...).

  1. In case of template units, the unit is meant to be enabled with some

instance name specified.

How can I fix this?

0
0

No need to enable, it is get auto configured while setup. And you can change which default Display Manager you want using:

dpkg-reconfigure gdm

Just reboot once.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.