4

I have a USB wifi adapter and I don't seem to make it work. it working before (2 months ago) but now it's not. running lsusb returns the driver:

Bus 001 Device 009: ID 0bda:b812 Realtek Semiconductor Corp. USB3.0 802.11ac 1200M Adapter

I'm not sure if the adapter is broken or I need a new driver and I looked on the internet and couldn't find and suitable driver for it.

Any help is much appreciated. I have already tried the solution here but didn't work. I think it's for some old drivers

1
  • Could you please run dmesg -w, then insert your wifi adapter, and post the output to your question?
    – ridgy
    Jan 30, 2021 at 21:12

1 Answer 1

14

The circa-2018 answer elsewhere here in AU is, I now believe, obsolete.

With a working internet connection by ethernet, tethering or whatever means possible, open a terminal and do:

sudo apt update
sudo apt install git dkms build-essential
git clone https://github.com/cilynx/rtl88x2bu.git
cd rtl88x2bu
VER=$(sed -n 's/\PACKAGE_VERSION="\(.*\)"/\1/p' dkms.conf)
sudo rsync -rvhP ./ /usr/src/rtl88x2bu-${VER}
sudo dkms add -m rtl88x2bu -v ${VER}
sudo dkms build -m rtl88x2bu -v ${VER}
sudo dkms install -m rtl88x2bu -v ${VER}
sudo modprobe 88x2bu

You will probably need to disable Secure Boot.

Your wireless should now be working.

1
  • 1
    Thanks a lot, this worked for me with ubuntu 20.04 Jul 3, 2021 at 10:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .