I am trying to install Android SDK on Ubuntu 12.04 but the Manager goes blank after downloading the first component of the SDK. I followed the installation steps mentioned here and tried to reinstall Ubuntu and nothing works. The terminal doesn't show any error messages the system monitor shows no network activity during this process.

Screenshot: enter image description here

Can anyone help? How can I get this to install?

4 Answers 4


It is highly recommended that you install ia32-libs so that the SDK is compatible with your 64-bit machine.

sudo apt-get update
sudo apt-get install ia32-libs

Or, if you're running Ubuntu 12.04, you may have to install ia32-libs-multarch instead:

sudo apt-get update
sudo apt-get install ia32-libs-multiarch

I've been maintaining this thread on XDA-Developers for a while now, I took bits & pieces from other forums, and put this method together. Googles method never worked for me, and made me hate Ubuntu. But, eventually it grew on me and I've gotten more advanced with Linux distros. Hope my thread can help someone. Enjoy the possibilities!!!!!



Follow this steps:

sudo apt-get install eclipse-jdt

Download Android SDK Starter Package

Download Android SDK Starter Package (From Official Site)

Now, Open Eclipse IDE and go to Help -> Install New Software then click on Add and enter the URL:


Install Android SDK:

Open Window -> Preferences and locate your Android SDK starter package.

Then go to Window -> Android SDK Manager, Select the packages you want to install and click Install [x] Packages.

Packages to select ?

Mandatory packages are SDK Tools, SDK – Platform Tools and the SDK platform (2.1 (recommended if you want to target for 97%+ users) or 4.0.3 (the latest version at the time of writing this post)) for which you want to write the Application.

Select other packages depending on your need, although most recommended packages are – Documentation, Code Samples, USB Driver, Google API, Google Analytics SDK, Google Admob Ads SDK (If you want to show ads in your App) etc. Don’t select unnecessary packages – that you don’t need now – otherwise it may take much time to download/install all those stuffs.

Wait, until the download/install process complete (it may take a lot of time if your Internet connection is not very fast).

That’s All.

Now it’s time start developing some cool Applications for Android.

Have Fun!


Install adb & fastboot via PPA (just adb & fastboot)

You can install from the WebUpd8 PPA which support both 32-bit and 64-bit. Granted you can install directly from google. But I prefer to use PPAs to keep everything up to date.
Works for Ubuntu 11.04, 11.10 and 12.04.

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install android-tools-adb android-tools-fastboot

Source: Install ADB And Fastboot Android Tools In Ubuntu Via PPA

Install Android SDK via PPA (full SDK)

If you want to install the SDK which will allow you to update everything you can install via the upubuntu ppa.

So first thing is to add the ppa.

sudo add-apt-repository ppa:upubuntu-com/sdk
sudo apt-get update
sudo apt-get install android-sdk

Only issue at this point is that android-sdk needs to be run as root. Well the link in the menu didn't do much. So I updated the link in the menu, you can also run:

gksu android-sdk

From there you will need to install "Android SDK Platform-Tools" I also recommend updating "Android SDK Tools". You can deselect anything else you don't need.

Example Selections

Now you will need to set your environmental variables.
First you will need to make everything executable.

sudo chmod -R 755 /root/android-sdk-linux

Now to add the variables.

nano ~/.bashrc

Add these lines (at the top)

#AndroidDev PATH
export PATH=${PATH}:/root/android-sdk-linux/tools
export PATH=${PATH}:/root/android-sdk-linux/platform-tools

Prepairing hardware. You need to make a udev rule for proper functioning. I did not need this step, but just incase.

gksudo gedit /etc/udev/rules.d/51-android.rules

Then copy & paste these lines.

SUBSYSTEM=="usb", ATTRS{idVendor}=="0bb4", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="0502", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="12d1", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="1004", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="22b8", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="04e8", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="0fce", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="0489", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="18d1", SYMLINK+="android_adb", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="04e8", MODE="0666", GROUP="plugdev"

These rules should work with most devices if not all.
Now we restart udev.

sudo restart udev

Now to test proper connection with adb & device.

adb devices

Source: Install Android SDK Manager (Revision 20) From PPA On Ubuntu 12.04/Linux Mint 13
Source: AndroidSDK - Community Ubuntu Documentation


I had similar problems on ubuntu 12.04 -64, nothing gets downloaded by the SDK manager. This seems to be due to https, but I haven't looked much deeper into it. I resolved the issue by updating sdk via command line SDK_HOME/tools/android update sdk --no-https --no-ui. Note also that android update sdk --no-https doesn't seem to work, the UI still uses https. This is likely a bug.


Not the answer you're looking for? Browse other questions tagged or ask your own question.