0

Ubuntu 18.04 (dual boot with Windows 10) on Dell Inspiron 5593.
This only happens when the laptop is not plugged in.

If I lock my screen or close my laptop, the computer suspends. When I try to wake the computer, I see my login screen, but I can't type my password. It just keeps displaying "Authentication Error." (I've seen a fix for this here, and configuring fs.inotify.max_user_watches solved my problem when plugged in, but not when unplugged.)

During the "Authentication Error" cycle, if I try Ctrl + Alt + F3, or if enough time passes, I'll see an endless stream of error messages; something like this:

EXT4-fs error (device nvme0n1p5) __ext4_find_entry:1532: inode #13894512: block 5557614: comm gmain: reading directory Iblock 0
EXT4-fs error (device nvme0n1p5) __ext4_get_inode_loc:4704: inode #13894512: block 5557614: comm systemd-journal: unable to read itable block

This is also demonstrated here with no clear solution, except to try memtest. I can't do memtest because I have UEFI boot only (see here).

fsck from a USB boot shows no errors.

It's also been suggested here that I should try downgrading the kernel, but that didn't help me either.

Can this be solved, or do I have a hardware malfunction?

Update I've just experienced this problem again when the computer was plugged in.

1
  • The problem did not go away, but I've at least side-stepped the problem by disabling S3 sleep in my Dell's system setup. It still locks the screen after a time, but I'm guessing it's a more shallow suspension, or not suspended at all. For that reason, I'll probably need to be careful about battery life if the screen locks while unplugged. Jan 30 at 19:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.