0

it seems that other possibilities than snap don't exist any longer.

The Oracle version produces other errors.

So i did:

snap install mysql-workbench-community

When i run it i get:

mkdir: cannot create directory ‘/run/user/0’: Permission denied
ln: failed to create symbolic link '/root/snap/mysql-workbench-community/7/.local/share/glib-2.0/schemas/org.gnome.desktop.a11y.applications.gschema.xml': File exists
ln: failed to create symbolic link '/root/snap/mysql-workbench-community/7/.local/share/glib-2.0/schemas/org.gnome.desktop.a11y.gschema.xml': File exists
ln: failed to create symbolic link '/root/snap/mysql-workbench-community/7/.local/share/glib-2.0/schemas/org.gnome.desktop.a11y.keyboard.gschema.xml': File exists
ln: failed to create symbolic link '/root/snap/mysql-workbench-community/7/.local/share/glib-2.0/schemas/org.gnome.desktop.a11y.magnifier.gschema.xml': File exists
...
(mysql-workbench-bin:932077): Gtk-WARNING **: 07:46:26.995: cannot open display: localhost:12.0

Ubuntu 20.04.2 LTS

Somebody running mysql-workbench without these errors?

0

Looks like you're trying to install a snap as root. Don't do that. Snaps are installed under a typical user account.

  1. Open Terminal (if not already open)

  2. Install the snap:

    $ snap install mysql-workbench-community
    
  3. Let it install, then output this message:

    mysql-workbench-community 8.0.22 from Tonin Bolzan (tonybolzan) installed
    
  4. Confirm it's available to run:

    MySQL Workbench

  5. Start the snap:

    MySQL Workbench Open

    Note: Starting seems to be painfully slow (~30 seconds).

I just went through all the steps to confirm the snap was still available and operational. Currently running Ubuntu 20.04.1 on the machine that did the work 👍🏻

7
  • snap install mysql-workbench-community error: access denied (try with sudo) – Bodo Jan 29 at 8:40
  • Before i did a snap remove mysql-workbench-community – Bodo Jan 29 at 8:41
  • Your hints are very welcome but i am using the server version of Ubuntu without GUI – Bodo Jan 29 at 8:42
  • Specificity is incredibly important when you're using a server and when you're asking random people on the Internet for assistance. MySQL Workbench is a client-side application, not something that runs on the server itself. – user1091774 Jan 29 at 8:53
  • I tried on a different VM -> install with sudo, execute as normal user -> success – Bodo Jan 29 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.