2

I want to install Open3D on Ubuntu 20.04 but I get the following errors. How could I fix it?

mona@goku:~$ wget https://github.com/intel-isl/Open3D/releases/download/v0.12.0/open3d-app-0.12.0-Ubuntu_20.04.deb
--2021-01-28 19:03:24--  https://github.com/intel-isl/Open3D/releases/download/v0.12.0/open3d-app-0.12.0-Ubuntu_20.04.deb
Resolving github.com (github.com)... 140.82.113.4
Connecting to github.com (github.com)|140.82.113.4|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://github-releases.githubusercontent.com/75413130/8cd1a380-4e88-11eb-9639-e33b0a383434?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20210129%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210129T000324Z&X-Amz-Expires=300&X-Amz-Signature=5f04a7b6d5eee8340ea6f3ebaf8fb2ac5a949d2e1bbfba71bcac6a3eea365a11&X-Amz-SignedHeaders=host&actor_id=0&key_id=0&repo_id=75413130&response-content-disposition=attachment%3B%20filename%3Dopen3d-app-0.12.0-Ubuntu_20.04.deb&response-content-type=application%2Foctet-stream [following]
--2021-01-28 19:03:24--  https://github-releases.githubusercontent.com/75413130/8cd1a380-4e88-11eb-9639-e33b0a383434?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20210129%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210129T000324Z&X-Amz-Expires=300&X-Amz-Signature=5f04a7b6d5eee8340ea6f3ebaf8fb2ac5a949d2e1bbfba71bcac6a3eea365a11&X-Amz-SignedHeaders=host&actor_id=0&key_id=0&repo_id=75413130&response-content-disposition=attachment%3B%20filename%3Dopen3d-app-0.12.0-Ubuntu_20.04.deb&response-content-type=application%2Foctet-stream
Resolving github-releases.githubusercontent.com (github-releases.githubusercontent.com)... 185.199.110.154, 185.199.111.154, 185.199.108.154, ...
Connecting to github-releases.githubusercontent.com (github-releases.githubusercontent.com)|185.199.110.154|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 110120788 (105M) [application/octet-stream]
Saving to: ‘open3d-app-0.12.0-Ubuntu_20.04.deb’

open3d-app-0.12.0-Ubuntu_20.04.d 100%[=========================================================>] 105.02M  5.11MB/s    in 22s     

2021-01-28 19:03:47 (4.74 MB/s) - ‘open3d-app-0.12.0-Ubuntu_20.04.deb’ saved [110120788/110120788]

mona@goku:~$ sudo dpkg -i open3d-app-0.12.0-Ubuntu_20.04.deb
[sudo] password for mona: 
Selecting previously unselected package open3d-viewer.
(Reading database ... 408548 files and directories currently installed.)
Preparing to unpack open3d-app-0.12.0-Ubuntu_20.04.deb ...
Unpacking open3d-viewer (0.12.0) ...
dpkg: dependency problems prevent configuration of open3d-viewer:
 open3d-viewer depends on libc++1; however:
  Package libc++1 is not installed.
 open3d-viewer depends on libglfw3; however:
  Package libglfw3 is not installed.

dpkg: error processing package open3d-viewer (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for shared-mime-info (1.15-1) ...
Errors were encountered while processing:
 open3d-viewer
mona@goku:~$ sudo apt install libc++1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libc++1 : Depends: libc++1-10 (>= 10~) but it is not going to be installed
 libopencv-highgui2.4v5 : Depends: libpng12-0 (>= 1.2.13-4) but it is not going to be installed
 open3d-viewer : Depends: libglfw3 but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
mona@goku:~$ sudo apt --fix-broken install libc++1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libc++1 : Depends: libc++1-10 (>= 10~) but it is not going to be installed
 libopencv-highgui2.4v5 : Depends: libpng12-0 (>= 1.2.13-4) but it is not going to be installed
 open3d-viewer : Depends: libglfw3 but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
10
  • Please add the output of apt-cache policy libc++1 libc++1-10 libopencv-highgui2.4v5 libglfw3 to the question.
    – N0rbert
    Jan 29, 2021 at 8:30
  • @karel It is deep third-party repository problem, please reopen to get this particular problem fixed.
    – N0rbert
    Jan 29, 2021 at 8:39
  • There is a duplicate of Norbert's answer to this question in the linked duplicate question.
    – karel
    Jan 29, 2021 at 8:40
  • @karel It is duplicate only in case of fresh installation. This means without 3rd party repositories.
    – N0rbert
    Jan 29, 2021 at 8:40
  • 1
    If I see incontrovertible evidence from the question's author that this question is insoluble by the aforementioned means then I will reopen it. Were it not for the possibility of package management errors that were caused by 3rd party repositories this .deb file could be installed by a one-liner apt command in 20.04 without any additional commands.
    – karel
    Jan 29, 2021 at 8:49

1 Answer 1

2

On fresh Ubuntu 20.04 LTS system without third-party repositories you have to install this package using apt to get dependencies resolved:

wget -c https://github.com/intel-isl/Open3D/releases/download/v0.12.0/open3d-app-0.12.0-Ubuntu_20.04.deb
sudo apt-get install ./open3d-app-0.12.0-Ubuntu_20.04.deb

The above package set will not require libpng12.

In your current situation you have to give additional information about used dependencies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.