1

I'm currently using Ubuntu 20.04 LTS. I'm having way too many issues with my computer right now, but I will start with trying to fix my WiFi. So I tried to install net-tools, but then this happened.

    patrick@patrick-Swift-SF315-51G:~$ sudo apt install net-tools
[sudo] password for patrick: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libc6-dbg : Depends: libc6 (= 2.31-0ubuntu9.2) but 2.31-0ubuntu9.1 is to be installed
 libc6-dev : Depends: libc6 (= 2.31-0ubuntu9.2) but 2.31-0ubuntu9.1 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

I tried this: apt --fix-broken install & apt-get -f install - received the same answer.

patrick@patrick-Swift-SF315-51G:~$ apt --fix-broken install
E: Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?

I also have received a notification from my Package Manager: The package system is broken

Check if you are using third party repositories. If so, disable them since they are a common source of problems. Furthermore, run the following command in a Terminal: apt-get install -f

The following packages have unmet dependencies:

  libc6-dbg: Depends: libc6 (= 2.31-0ubuntu9.2) but 2.31-0ubuntu9.1 is installed
    libc6-dev: Depends: libc6 (= 2.31-0ubuntu9.2) but 2.31-0ubuntu9.1 is installed
               Depends: libc-dev-bin (= 2.31-0ubuntu9.2) but 2.31-0ubuntu9.2 is installed

So my question is, how can I fix the broken packages and use Sudo apt-get install again?

Thank you for your time.

Edit: I tried sudo apt-get clean & sudo apt-get update Then I tried Sudo apt-get -f install, same result.

    Errors were encountered while processing:
 /var/cache/apt/archives/libc6_2.31-0ubuntu9.2_amd64.deb
 /var/cache/apt/archives/libc6_2.31-0ubuntu9.2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I also tried to sudo dpkg --configure -a; and received this

dpkg: dependency problems prevent configuration of libc6-dbg:amd64:
 libc6-dbg:amd64 depends on libc6 (= 2.31-0ubuntu9.2); however:
  Version of libc6:amd64 on system is 2.31-0ubuntu9.1.

dpkg: error processing package libc6-dbg:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libc6-dev:amd64:
 libc6-dev:amd64 depends on libc6 (= 2.31-0ubuntu9.2); however:
  Version of libc6:amd64 on system is 2.31-0ubuntu9.1.

dpkg: error processing package libc6-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.31-0ubuntu9.1) ...
Errors were encountered while processing:
 libc6-dbg:amd64
 libc6-dev:amd64
2
  • 1
    Run that fix-broken command again, but prepend the command with sudo Jan 28 at 17:57
  • Thank you, but unfortunately, it didn't work. Jan 29 at 18:31
0

Try the following workflow

sudo apt-get clean

sudo apt-get update

sudo apt-get -f install

sudo dpkg --configure -a

2
  • I'm sorry, It just returns back to the error: Errors were encountered while processing: /var/cache/apt/archives/libc6_2.31-0ubuntu9.2_amd64.deb /var/cache/apt/archives/libc6_2.31-0ubuntu9.2_i386.deb E: Sub-process /usr/bin/dpkg returned an error code (1) And when I tried dpkg --configure -a, it shows which packages are broken: dpkg: error processing package libc6-dev:amd64 (--configure): dependency problems - leaving unconfigured Processing triggers for libc-bin (2.31-0ubuntu9.1) ... Errors were encountered while processing: libc6-dbg:amd64 libc6-dev:amd64 Jan 29 at 18:25
  • It might be diffucult to read in the comment, so I will add it in the Question Jan 29 at 18:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.