0

Basically, I do not totally understand how GNOME the whole stuff works.

As the title shows, I am currently working on using TigerVNC to start a GNOME desktop, which is separate from the original GNOME when I use a physical screen to log in.

Here is my physical desktop appearance.

Here is my ~/.vnc/xstartup script (xstartup): And I ran it by vncserver -verbose -localhost yes :2

#!/bin/sh

# Change "GNOME" to "KDE" for a KDE desktop, or "" for a generic desktop
MODE="GNOME"

#Uncommment this line if using Gnome and your keyboard mappings are incorrect.
# export XKL_XMODMAP_DISABLE=1

# Load X resources (if any)
if [ -e "$HOME/.Xresources" ]
then
        xrdb "$HOME/.Xresources"
fi

export GNOME_SHELL_SESSION_MODE=ubuntu

# Try a GNOME session, or fall back to KDE
if [ "GNOME" = "$MODE" ]
then
        if which gnome-session >/dev/null
        then
                # see /usr/share/gnome-session/sessions/ubuntu.session for more info
                dbus-launch --exit-with-session gnome-session --session=ubuntu --debug &
        else
                MODE="KDE"
        fi
fi

# Try a KDE session, or fall back to generic
if [ "KDE" = "$MODE" ]
then
        if which startkde >/dev/null
        then
                startkde &
        else
                MODE=""
        fi
fi

# Run a generic session
if [ -z "$MODE" ]
then
        xsetroot -solid "#DAB082"
        x-terminal-emulator -geometry "80x24+10+10" -ls -title "$VNCDESKTOP Desktop" &
        x-window-manager &
fi

Notice there are two icons missing on the left (one is Terminal app)

I am a newbie to the whole GNOME stuff.

Hope someone can give me some suggestions!


I have also tried replace dbus-launch --exit-with-session gnome-session --session=ubuntu --debug & with dbus-launch --exit-with-session gnome-shell &.

It turned out the icons were back, but my Settings window was blank.

The left side icons were back but Settings' windows was blank

The error message from tigervnc:

Thu Jan 28 22:13:02 2021
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on local interface(s), port 5902
 vncext:      created VNC server for screen 0
GNOME Shell-Message: 22:13:02.986: Telepathy is not available, chat integration will be disabled.
Gjs-Message: 22:13:03.130: JS WARNING: [/usr/share/gnome-shell/extensions/ubuntu-dock@ubuntu.com/appIcons.js 1028]: unreachable code after return statement
Gjs-Message: 22:13:03.159: JS WARNING: [resource:///org/gnome/shell/ui/workspaceThumbnail.js 891]: reference to undefined property "_switchWorkspaceNotifyId"

(gnome-shell:15336): Bluetooth-WARNING **: 22:13:03.209: Could not create bluez object manager: GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: Rejected send message, 2 matched rules; type="method_call", sender=":1.6794" (uid=1001 pid=15336 comm="gnome-shell " label="unconfined") interface="org.freedesktop.DBus.ObjectManager" member="GetManagedObjects" error name="(unset)" requested_reply="0" destination=":1.2" (uid=0 pid=1025 comm="/usr/lib/bluetooth/bluetoothd " label="unconfined")
GNOME Shell-Message: 22:13:03.384: Error looking up permission: GDBus.Error:org.freedesktop.portal.Error.NotFound: No entry for geolocation

(gnome-shell:15336): AccountsService-WARNING **: 22:13:03.577: Could not get current seat: No data available

I have also followed the instructions in Arch Linux-TigerVNC Namely, adding this file into ~/.vnc/config and removing xstartup script.

session=ubuntu
geometry=1920x1080
localhost
alwaysshared

Unfortunately, my icons were still different from my original GNOME desktop :(


Here is my current theme:

$ gsettings get org.gnome.desktop.interface icon-theme
'Adwaita'

I don't know if this was caused by Adwaita icons. For example, here is my /usr/share/applications/org.gnome.Terminal.desktop

[Desktop Entry]
Name=Terminal
Comment=Use the command line
Keywords=shell;prompt;command;commandline;cmd;
TryExec=gnome-terminal
Exec=gnome-terminal
Icon=utilities-terminal
Type=Application
X-GNOME-DocPath=gnome-terminal/index.html
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=gnome-terminal
X-GNOME-Bugzilla-Component=BugBuddyBugs
X-GNOME-Bugzilla-Version=3.28.2
Categories=GNOME;GTK;System;TerminalEmulator;
StartupNotify=true
X-GNOME-SingleWindow=false
OnlyShowIn=GNOME;Unity;
Actions=new-window
X-Ubuntu-Gettext-Domain=gnome-terminal

NoDisplay=true

[Desktop Action new-window]
Name=New Terminal
Exec=gnome-terminal

I found that ./Adwaita/scalable/apps/utilities-terminal-symbolic.svg whose basename is not utilities-terminal

0

Eventually, I solved it by apt install -y gnome-tweaks and tweaked the icon-theme back to Ubuntu-mono-dark then my icons came back. I found that the issue of missing icons is a feature for Adwaita icon-theme rather than a bug.

But I have never changed org.gnome.desktop.interface icon-theme to another theme. I still wondered why org.gnome.desktop.interface icon-theme suddenly changed (And the changes only happened in my gnome-session viewed from my VNC viewer, while the physical GNOME was intact.) (Perhaps because I kill the gnome process, causing all settings to become the default (Awaita seems like a default setting of gnome)?)

0

The Gnome icon set available with the base Ubuntu desktop install is incomplete. Try installing the gnome-icon-theme package. I discovered this accidentally when setting up the Numix theme, which depends on some of the missing Gnome icons.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.