0

Ok So I am trying to install tor browser by commands

apt-get install tor torbrowser-launcher  

also tried sudo apt-get install tor torbrowser-launcher

but The error I am getting is

E: Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?

Actually before this I was getting some other errors from dpkg which denied me permissions. So I ran some commands to remove some 3 lock files but I also removed lock-frontend after that. It was written in some article. So what should I do now?

7
  • I tried that but problem still remains the same Jan 28, 2021 at 9:21
  • What did you try?
    – Kulfy
    Jan 28, 2021 at 9:21
  • sudo apt-get update and sudo apt-get dist-upgrade Jan 28, 2021 at 9:21
  • If you re-read first or second answer, you may conclude that you need to run apt-get commands with elevated privileges, i.e., with sudo. Try running sudo apt-get install tor torbrowser-launcher.
    – Kulfy
    Jan 28, 2021 at 9:23
  • thanks sudo command is working now, i don't know what mistake i was doing earlier with that command but now it is working. Jan 28, 2021 at 9:31

0

Browse other questions tagged .