1

Having bought a new motherboard & CPU, I did a clean install of xubuntu 20.10 yesterday which fixed a number of small bugs but has caused a strange one: My second display is an LG TV connected by HDMI: display

And looks right in xrandr: xrandr

The display output seems to be extended to this display based on the fact that I can drag my mouse off the primary and it goes a long way (sounds dumb but you know what I mean). BUT: on the TV, it says no HDMI is connected. I haven't touched the cable since yesterday so it seems unlikely to be a physical cable connection issue. MORE weirdly, if I mirror displays, the HDMI signal IS detected by the TV and it turns on. It looks garbage but proves the connection is viable. Weirder still, back on normal extended mode, if I set the audio output to the HDMI (rather than displayport to monitor1), sound WILL come out of the TV system. But no video. So signal will go from PC to TV via HDMI cable in mirrored and extended mode... just not video.

I've tried with Xserver/nouveau/whatever it's called, and Nvidia display adapter. No change. Weirder still, the same seems to happen in my dual-boot win10 install.

Any ideas for how to solve this? Maybe unplug the HDMI from both ends, reboot both PC & TV, plug in PC, plug in TV, retry?

Also, since I first plugged in the TV a few months back, my login screen display settings are a janky mix of the resolution of both displays: normal box size, big mouse cursor size, and often takes a while to force it to select the form field:

login weirdness

Any ideas for this also appreciated. Thanks!

Edit: I shut down the PC, removed the HDMI, and booted up. Login screen weirdness gone (unsurprisingly). Plugged in HDMI, TV detected, automatically gets placed as display1 in 'semi mirrored' mode where the screens are overlapped. Click 'mirror displays' to make actually mirrored. No change. Click again to make extended. No change. Unplugging & replugging the HDMI at the TV has the same result: overlapping screens when first detected, TV as display1, no effect from 'mirror displays' button.

I believe there's a Nvidia hardcoded rule that says primacy order of connected displays is VGA, HDMI, DP. Not sure whether HDMI being before DP is relevant to this case (given it's the likely reason the TV is assigned as display1 when both are connected).[edit: TV being display1 would explain the oversized login screen box]

Edits for my notes: now 1920x1080 on LGTV is a very letterboxed display despite being the same ratio (1.777) as full res (3840x2160), whereas 1980x1200 fills the screen but is a different ratio (1.6). Also accepts 1920x1440 (1.333), 2048x1536 (1.333), 2560x1600 (1.6), 2880x1620@60 (1.777)

Doesn't like: 2560x1440 (1.777), 3200x1800 (1.777), 3840x2160 (1.777), 4096x2160 (1.8962). Saving these edits then will try the same in windows. Somewhat suggests the GPU doesn't have the power to output that many pixels (1080Ti OC) but I'm prettymuch positive it was doing so before, on a less good motherboard with less RAM installed.

In Win10, options are limited: 3440x1400, 2560x1600, 2560x1440, 2048x1536, 1920x1440, 1920x1200, 1920x1080. None do anything in extended mode. Nor duplicated. In 'show only on monitor2' I tried 1920x1080 and it didn't work.

1080 Ti max HDMI resolution is 4096 x 2160 @ 60 Hz, so the GPU is defo capable (as I know since it used to do it fine). I'm increasingly feeling like it's the BIOS since that's the only thing that's changed. And it doesn't work in windows at all.

Highly unproductive & slow online chat with Asus. Win 10, in powershell $env:firmware_type returns UEFI so it seems windows was installed in UEFI, & msinfo32 says it's booted in uefi also, so CSM boot mode isn't in play so that idea is dead.

Turn secure boot on?

PCI-E slot issue? (I think only the first slot is 16x but I might be mistaken) [edit: no benefit from PCIe3 slot, see below]

"It may be with the GPU drivers or windows itself. You may try to clear CMOS and also update the BIOS for further troubleshooting."

I emailed Gigabyte (GPU) and LG (TV monitor).

Just watched an old AVI movie on the TV @ 2880x1620 on xubuntu, and it would cut to black every so often, intermittently, more by the end of the movie than the start. Nothing wrong with the file when playing on the primary monitor.

Edit: more thoughts:

Ryzen 5 5600x doesn't have integrated graphics. So although my mobo has an HDMI port & supports HDMI 2.1 @ 4k 60Hz, I can't power that from the CPU so game over on that front.

GPU 1080ti incompatible with the PCIe4x16 port on the new mobo, compared to PCIe3x16 on the old one? New mobo manual says the second slot is PICe3x16 but "supports x4 mode". If that's PCIe3x4=3940MB/s. If PCIe4x4=7876MB/s. Apparently pcie3x4 provides 97% the performance of pcie3x16 for a 1080. Just benchmarked it with GPU in either slot and PCIe3 delivers 95% of the FPS of PCIe4 but min FPS is 30 compared to 8. If that's true then it's an ok tradeoff maybe, IF the second monitor worked in Windows. It doesn't. In Xubuntu, works: 1920x1440x60, 2048x1536x60, 2560x1440x60, 3840x2160x30 (native half refresh rate) Doesn't: 2560x1600x60 (did before), 2880x1620x60, 3200x1800x60, 3840x2160x60 (native) also x59.9, x50, 4096x2160x60.

Testbench results of xubuntu20.10 & win10 for 1080ti in PCIe4 & PCIe3:

testbench

PCIe slot summary: PCIe3 conferred no benefit and produced 95% the FPS output in GPU benchmarking compared to PCIe4, which is a hit I'd maybe be prepared to take if the HDMI output to TV worked, which it didn't. In Xubuntu I can run native res @ 30hz, or max 2880x1620 @ 60hz. Win10 runs nothing except a dull & occasionally flickering display at low res with interlaced refresh rate, or turns on & looks normal for a millisecond, then off for a while, then no signal, then repeat. Two biggest takehomes thus far:

  1. The max pixels per second xubuntu is capable of is 279,936,000. Native res & refresh is 497,664,000. IDK whether pixels per second is even a thing but it seemed logical. That the previous setup (mobo & CPU) was capable of the full PPS and the current one isn't suggests to me that the current setup has some kind of hardware compatibility issue.

  2. Xubuntu can produce max res 30hz or slightly down-res 60hz, while windows can produce basically nothing, with exactly the same hardware settings. Therefore the OS and driver setup on windows is to blame for its inability to produce the same stuff as xubuntu can. And if I can achieve that I'm PROBABLY fine. Would I like it to do its actual job? Sure. But after HOURS of diagnosis, I'll take it.

Edit: something from another page, probably not helpful but will test later: "if you recently upgraded to Windows 10, it upgraded your HDMI output to 2.0 too. If you have an older monitor, then it’s most likely not compatible with it". Monitor is new LG TV 2021, very likely compatible. GPU is 1080ti, presumably compatible. Ditto cables. Remember gpu + cable + tv + win10pro all worked before.

5
  • 1
    Is there any difference if you set the TV output to 1920x1080 (and you could try a few refresh rates if it lets you). e.g. does screen extending then work or same problem (mirror works but extending does not work?). – codlord Jan 28 at 8:44
  • oh. wow. yes! that works (1920x1080x100Hz (max refresh is 100)). Though no higher resolutions work, regardless of refresh rate. I'm sure it was working at 3840x2160x60 before; I wonder why this is no longer an option...(or rather, I wonder why this no longer works). Video card incapable? It worked before. That said, I was using XOrg before and currently I'm on Nvidia driver. Switched to Xorg, same issue. Don't suppose you have any guesses as to why this might be? Thanks a lot for the advice so far! – dez93_2000 Jan 28 at 9:48
  • 1
    Could be hardware, look up to see what the hardware supports but not always easy given multiple things could be a factor (graphics hardware, drivers, hdmi port, multiple monitors etc). It could be your HDMI cable, I have found with lower resolutions most HDMI cables will be fine but sometimes when you start to get to 4k the cable needs to support the bandwidth that requires. So try different cable or buy a legit hdmi 2.0 or 2.1 cable. Last thing you could try is adding a custom resolution using "reduced blanking" see here: wiki.archlinux.org/index.php/Xrandr#Troubleshooting – codlord Jan 28 at 10:35
  • I only changed the motherboard and it's an upgrade so the cable and GPU and TV have all worked together before. With the xrandr custom res, the desired res & hz is already an option... You think the blanking will help? This is an OLED screen which doesn't blink, just doesn't come on at all. Cheers for the ideas, again! One thing I saw elsewhere was about disabling secure boot but IDK that it's on already, and the things it supposedly prevents (e.g. dual boot) I'm using fine... – dez93_2000 Jan 28 at 11:11
  • Another thing re the HDMI cable: this still wouldn't explain why xubuntu would output 2880x1620but Win10 won't output anything. Just checked & my HDMI cables support 3840x2160@60Hz – dez93_2000 Feb 9 at 23:27
0

Solved thanks to Asus tech manager:

Nvidia control panel resolution settings:

RGB / 8 bpc / limited FAIL

RGB / 8 bpc /full FAIL

RGB / 12 bpc / limited FAIL

RGB / 12 bpc /full FAIL

tested some parameters & failed: YCbCr422, YCbCr444

YCbCr420 wasn't even an option until I tried RGB / 12 bpc / full / 60Hz.

YCbCr420 / 12 bpc FAIL

YCbCr420 / 8 bpc SUCCESS

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.