0

I have installed SQL Server 2019 onto a new Ubuntu instance with 4GB of Ram following the fact it would sometimes crash on an older Ubuntu 20.10 instance with 3GB of Ram. However the problem is even worse on the new server and it seems to fail after about an hour and just says the service is dead if running sudo systemctl status mssql-server. SQL Server 2017 and then 2019 used to run happily on this VM with just 3GB of Ram.

I have 13 databases on the server which are all under a GB (most are 50MB to 200MB) and there should only ever be a handful of connections to these databases.

The error I see is:

mssql-server.service: Main process exited, code=exited, status=255/EXCEPTION

I have tried constraining the memory to be 2GB or 3GB or leaving it set to a much higher value as it is by default. 2GB appears to be the minimum supported and I would have thought that would have sufficed.

I really don't know what to do to keep this SQL Server instance from crashing and exiting. The server has CPU and memory available and other services are unaffected and remain running.

Everything is up to date using apt upgrade and SQL Server shows as version 15.0.4083.2.

I would appreciate any help/ideas.

Thanks Robin

0

I think I may now have found the solution.

Checking for updates unixodbc kept being held back and I noticed it said ODBC so thought it might be related to the issues. It seemed to be failing to install as multiarch support was missing as trying apt install unixodbc resulted in a different error about the missing multiarch support and unmet dependencies.

I ran the following to install multiarch support:

cd ~/Downloads
wget http://archive.ubuntu.com/ubuntu/pool/main/g/glibc/multiarch-support_2.27-3ubuntu1.4_amd64.deb
sudo apt-get install ./multiarch-support_2.27-3ubuntu1.4_amd64.deb

(from Installing odbcins1debian2, broken dependency on Ubuntu 20.04 LTS)

Then running apt upgrade installed unixodbc and my SQL Server has remained working since then. It was managing about an hour before but now it's up to 3hrs 10 mins so hopefully this is now solved. This was a fresh install of Ubuntu 20.10 so presumably everyone trying to install to this version would hit this same issue. It seems older versions of unixodbc didn't require multiarch support.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.