0

I use Ubuntu 20.04.1.; Kate 20.04.0 was installed with sudo snap install kate

When I start Kate I get first the message
Qt: Session management error: Could not open network socket
and then pages of error messages.

Any hint how to get out of this mess?

alex

4

First remove the SNAP package, then install the apt version.

$ sudo snap remove kate
...
$ sudo apt install kate
...
$ kate --version
kate 19.12.3

This might not be the latest version, but it sure works (20.04)

To me snap packages are a nuisance due to not having "sane" security settings provided with/inside them, and most of all NOT adjusted to a home user's needs.

5
  • But wouldn't this install a mountain of KDE dependencies? – Levente Jan 26 at 17:38
  • Unavoidable, with snap too. – Hannu Jan 26 at 17:43
  • FWIW; my / resides on a 256GB SSD, all of it, including kate and KDE, sums up to 12.4GB of data; That is 0.0124 TB - not very much, despite numerous fun and useful packages being present. 230 of 244.5 GB available. (Hit the windows key and type Disk Usage Analysator to check yours) – Hannu Jan 26 at 17:55
  • The disk usage side is convincing enough indeed; but I'm also concerned about how many of those extra / otherwise redundant modules are loaded along with the Gnome desktop, like, impact on RAM usage, and a general impact on the system's stability. Is there such a thread that explores this? I love Kate; I had positive experiences with it (from an earlier time in my life). But these aforementioned concerns kept me from installing it... – Levente Jan 26 at 18:27
  • Thank you for the hint. It worked. – afs Jan 27 at 22:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.