Laptop: Dell G5 5590
Windows 10, Version 10.0.18363 Build 18363
Ubuntu Studio 20.04.1
Drive: M2.2280 NVMe 2TB

I have tried several approaches to dual booting, with the one where I was finally able to boot to the USB drive at "Dual boot Ubuntu 16.04 with preinstalled Windows 10 Dell G5 5587"

To recap my steps;

Download Ubuntu iso file from Ubuntu website.
Download Rufus from Rufus website.
Burn the ISO to a Pendrive
Insert a USB pendrive.
Open Rufus.
Select Partition Scheme MBR. *Keep the other settings to default. E.g.: FAT.
Select the ISO and burn it to the connected pendrive.

I had previously cloned my Windows 10 from a 512G NVMe to a 2TB NVMe, and left 1TB as free space
Disabled Fast Start
Disabled Secure Boot
Set Boot Mode to Audit
Enabled AHCI for dual boot ad described in the link above
Turned off PTT
After the OS burn, inserted the pendrive and restart the machine.
Pressed F12.
Selected USB/Removable media.
Selected install Ubuntu.
Selected Language and other options.
When it comes to partition option, select something else.
In the 1 TB of unallocated space:
Per the Dell Dual Boot advice, then added a Root partition /
Gave 30 GB Logical space to swap memory in another /swap partion
The rest went to the /home partition.

The sticking point came with "Device for boot loader installation". The first link said to assign it to "Windows Boot Manager", and obviously there was no such device listed. In other links I read, it said to select the Windows 10 partition with the Windows Boot Manager, which is on the system partition labeled ESP. enter image description here

On my drive, that partition is /dev/nvme0n1p1 (fat32), so I selected that device. I did not add a Boot Option file.

Upon hitting "Install Now", a warning came up saying "The partition table format in use on your disks normally requires you to create a separate partition for boot loader code This partition should be marked for use as a "Reserved Bios Boot Area" and should be at least 1 MB in size."

enter image description here

I exited the install, and it dropped me back into Ubuntu Studio, with all of the drives I had partitioned showing up on the desktop.

I exited Ubuntu Studio, and restarted. Windows 10 came up like normal.

Q. What should I do now;
1. Repeat the process, except use /dev/nvme0n1 for "Device for boot loader installation"?
2. or something else?

UPDATE 1/26:

I made another install USB with Rufus, this time going with GPT and UEFI (non CSM). I tried to boot to that install, though the screen simply remained blank. So I hard restarted and tried again. Same issue. So I rebooted, though this time when I let it default to Windows, a fault screen showed up, requiring a repair via Windows Recovery Drive. I did so, then rebooted to windows with no issue.

Next I tried another install with MBR and UEFI/BIOS and was able to boot into Ubuntu install. When it came time to select the drive partitions, it showed that a previous install of mine populated the /, /swap, and /home partitions. So I have an install waiting for me to put the grub in the right place. So I exited, rebooted to the UEFI menu, and added boot options to EFI/BOOT64_efi and grubx64.efi, with Windows Boot Manager as the last option.

enter image description here

Rebooting then simply brought up Windows. Am I close?

  • 1
    You show an ESP - efi system partition, so Windows is UEFI? If using Rufus you need to use gpt & UEFI as it creates only BIOS or only UEFI install flash drives from ISO. Other tools create flash drive for both & you select when booting in UEFI boot menu. Whether UEFI or BIOS you alway install boot loader to a drive, never to a partition. If grub installed to NTFS, it will break Windows. BIOS boot on gpt requires the bios_grub partition which you do not want. You want to install in UEFI mode. help.ubuntu.com/community/UEFI
    – oldfred
    Jan 24, 2021 at 19:44
  • @oldfred yes, BIOS mode is UEFI. On the one link I shared, the Rufus USB setup had MBR identified, though I'll try it now with GPT and UEFI. And I'll install the boot loader on the drive at /dev/nvme0n1
    – Will
    Jan 24, 2021 at 20:54
  • @oldfred , please see update, thank you
    – Will
    Jan 27, 2021 at 1:33
  • 1
    You do not need that large of a swap partition. New installs now uses a 2GB swap file, but swap partition will be used if found. Only 4GB is often suggested fro those who want swap partitions, usually server type installs. Be sure to boot in UEFI mode. Lets see details, use ppa version with your live installer (2nd option) or any working install, not Boot-Repair ISO: Please copy & paste the pastebin link to the Boot-info summary report ( do not post report), do not run the auto fix till reviewed. help.ubuntu.com/community/Boot-Repair
    – oldfred
    Jan 27, 2021 at 3:46
  • 1
    You have grub in the PBR or BS partition boot sector of the eSP your FAT32 nvme0n1p1. I know with Windows that breaks Windows. Grub is not normally installed to a partition and never to NTFS. Not sure if FAT32 has a backup like NTFS, but I would try that first. You want to get to this screen, if it also works for FAT32: cgsecurity.org/wiki/… If you cannot recover it, then in the future you may have issues as partition will not be seen correctly. Testdisk may say it is valid as grub can be valid in PBR, but it still is not normal.
    – oldfred
    Jan 27, 2021 at 19:40


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy