0

I have a USB sound device (using the Micronas UAC3556B CODEC) that is occasionally connected to my computer. When I plug it in, capturing is by default enabled for the Line input and disabled for the Mic input. The software I use needs to have capturing enabled for both Line and Mic input. I can do this manually using

amixer -c 2 set Mic cap

But I found no way to do this automatically when the device is plugged in. I already tried

  1. a udev rule that executes the command:ACTION=="add", SUBSYSTEM=="sound", ATTRS{idVendor}=="074d", ATTRS{idProduct}=="3556", RUN+="/usr/bin/amixer -c 2 set Mic cap"

  2. make the changes manually and store them using sudo alsactl store -l.

In both cases, I saw that the change is applied, but when I checked with amixer -c 2 get Mic, the capturing was disabled again for the Mic input. So it seems something is running after the udev rule that changes the settings of the sound device.

What did I miss in my ALSA configuration?

I'm using Ubuntu 20.04 LTS.

1
  • Any question should always include the version of Ubuntu you are using. What version is it?
    – David
    Jan 24 '21 at 13:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.